cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Projects lost after installing Thingworx for Manufacturing Application 8.4 w/ existing foundation

eyli
12-Amethyst

Projects lost after installing Thingworx for Manufacturing Application 8.4 w/ existing foundation

I have a server with Thingworx Foundation 8.4 installed. Then I installed Thingworx for Manufacturing Application on it and found all my projects lost. Is this a normal situation? 

1 ACCEPTED SOLUTION

Accepted Solutions
slangley
23-Emerald II
(To:eyli)

Hi @eyli.

 

It sounds like you are installing the trial products, correct?  If so, by running the Mfg Apps installer after running the ThingWorx installer, you most likely overwrote your previous installation.

 

If you are just evaluating the product for now, please be assured that when you purchase the product, you will not lose your projects as long as the installation procedure is followed.  Note that once ThingWorx platform is installed, the procedure for installing Mfg Apps would be to simply import the needed extensions.

 

If you feel this response explains the issue you encountered, please mark it as the Accepted Solution for the benefit of others on the community.

 

Regards.

 

--Sharon

View solution in original post

5 REPLIES 5
slangley
23-Emerald II
(To:eyli)

Hi @eyli.

 

I'll do some research to see if this issue has been previously reported, and if not, I will test it.  Please provide the full version of both ThingWorx and ThingWorx Mfg Apps.

 

Regards.

 

--Sharon

eyli
12-Amethyst
(To:slangley)

Thanks for your answer. "Thingworx for Manufacturing Application" version is 8.4.0-b2013. But I only remember Thingworx foundation is 8.4. I don't remember its detailed version number.

slangley
23-Emerald II
(To:slangley)

Hi @eyli.

 

I did some research but found no reports of this issue.  So I tested under ThingWorx 8.4.0/Mfg Apps 8.4.0 as well as ThingWorx 8.4.3/Mfg Apps 8.4.3.  I was unable to recreate this issue.

 

To be able to investigate further, please provide more details of your environment:

 

  • What is the exact version of ThingWorx?  You can find this in Composer under Help > About.
  • What was your procedure for installing Mfg Apps?

Regards.

 

--Sharon

eyli
12-Amethyst
(To:slangley)

hi @slangley 

 

Please see my answer below.

  • What is the exact version of ThingWorx?  You can find this in Composer under Help > About.
    • [eyli: It is now 8.4.0-b2013]
  • What was your procedure for installing Mfg Apps?
    • I installed Thingworx foundation 8.4 at first. Then I downloaded the "ThingWorx-Manufacturing-Apps-8.4.0-00.exe" and installed it. I don't remember the details. But I guess the original Thingworx foundation could be uninstalled automatically when "ThingWorx-Manufacturing-Apps-8.4.0-00.exe" was installed.
slangley
23-Emerald II
(To:eyli)

Hi @eyli.

 

It sounds like you are installing the trial products, correct?  If so, by running the Mfg Apps installer after running the ThingWorx installer, you most likely overwrote your previous installation.

 

If you are just evaluating the product for now, please be assured that when you purchase the product, you will not lose your projects as long as the installation procedure is followed.  Note that once ThingWorx platform is installed, the procedure for installing Mfg Apps would be to simply import the needed extensions.

 

If you feel this response explains the issue you encountered, please mark it as the Accepted Solution for the benefit of others on the community.

 

Regards.

 

--Sharon