cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Same mashup not working in another server

TanmeyTWX
15-Moonstone

Same mashup not working in another server

Hi Experts,

 

I have come across a scanerio multiple times where same mashup does work on one Thingworx instance and doesn't respond on another instance.

Though both Thingworx servers are identical in terms of version, corresponding platform settings and even Thingshape services. But still not responding.

 

Issue description: Mashup has an advanced grid bound to data service which gets triggered on two events i.e. on Mashup load and Navigation popup close. But the service is not getting triggered to refresh grid post popup close.

Same mashup has been deployed on a new Thingworx instance and working.

I have debugged each and every binding but no luck.

 

Did you come across similar issues and any solution you have discovered?

 

TIA.

2 REPLIES 2
TanmeyTWX
15-Moonstone
(To:TanmeyTWX)

One more observation: same issue is occurring wherever I have a service to be triggered after popup(navigation) close.

 

Looks like Mashup Parameter not persisting the value after popup close. Hence after popup close Mashup parameter is coming as undefined which is further not triggering the service.

 

Any suggestions on it?

 

slangley
23-Emerald II
(To:TanmeyTWX)

Hi @TanmeyTWX.

 

Which version of ThingWorx are you running?  You can use the browser Dev tools (F12) to identify the failure point.  You may also want to check the logs and turn up the logging level, if necessary.

 

Regards.

 

--Sharon

Announcements