cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need to share some code when posting a question or reply? Make sure to use the "Insert code sample" menu option. Learn more! X

Kepware IOT Gateway JAVA JRE

VM_8674327
4-Participant

Kepware IOT Gateway JAVA JRE

For the IoT Gateway to run, KEPServerEX requires a working 32-bit Java JRE or full JDK installation version 7 or higher. At this time, a 64-bit JRE or JDK is not supported. I Just wanted to know if we can use AdoptOpenJRE instead of 32-bit java JRE?  

1 ACCEPTED SOLUTION

Accepted Solutions

The only third-party tested versions of Java at this time are OpenJDK & Correcto (Amazon’s openjdk) as shown in this knowledge article here:

 

https://www.ptc.com/en/support/article/cs325523

 

If you attempt to use an alternate version of Java, proper functioning of the IOT Gateway plugin is not guaranteed and cannot be supported.

 

Best regards,

Andy Servetas
Principal Technical Support Engineer | Kepware Technologies

 

 

 

 

View solution in original post

1 REPLY 1

The only third-party tested versions of Java at this time are OpenJDK & Correcto (Amazon’s openjdk) as shown in this knowledge article here:

 

https://www.ptc.com/en/support/article/cs325523

 

If you attempt to use an alternate version of Java, proper functioning of the IOT Gateway plugin is not guaranteed and cannot be supported.

 

Best regards,

Andy Servetas
Principal Technical Support Engineer | Kepware Technologies

 

 

 

 

Top Tags