cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Cross hatching disappears w/ z-clipping

SOLVED
Bedrock

Cross hatching disappears w/ z-clipping

I've searched for a solution for this but found none so I thought I would ask this question again.

 

In a drawing view that uses a 2D section, the cross hatching for parts disappears when z-clipping is turned on.

 

Does anybody know why and is there a work around?

 

Thanks,

 

Steve

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cross hatching disappears w/ z-clipping

I did submit a PTC Support Case and they haven't determined what was causing the PAT hatch problem.

 

I just discovered that if I use a datum point to set the z-clipping depth (instead of a datum plane) the PAT hatch does show and fixes the problem.

 

Because of this, it almost makes you think the original datum plane that I was using for z-clipping wasn't parallel to the view plane. But the z-clipping datum plane was parallel because it was created using an offset.

 

I'm happy. I now have a work-around.

View solution in original post

15 REPLIES 15

Re: Cross hatching disappears w/ z-clipping

Hi Steve,

 

I am not 100% sure but you may try turning off the HLR for xhatching, this may fix the issue.

 

View properties> View display > Hidden line removal for xhatches as No

Re: Cross hatching disappears w/ z-clipping

Thanks for the reply. That didn't fix the issue.

 

Steev

Re: Cross hatching disappears w/ z-clipping

I'm on Creo 4 and I don't see this.

Just double check and make sure your z-clipping is on the "correct" side of the section...occasionally I make that mistake, usually the z-clip will grab something hidden that I didn't expect. Look for the z-clip "x" on a projection view to see which side of the x-section arrow it's on.

Does this happen only on one drawing or all your drawings? If ALL, then it's probably one of your settings, sometimes config.pro, sometimes drawing setup. For the config, you might try starting creo with no configs (rename them temporarily) and then reopen the drawing and if it's works, its a config setting.

Drawing setup is a little more difficult. You could look at the setup for that drawing and change everything that is not default to default (look for the asterisks by the value). Make sure you don't save the drawing this way since it may make unexpected changes that may be harder to undo.


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)

Re: Cross hatching disappears w/ z-clipping

Stephen thanks. Still not working the way I would suspect it to. I'll explain.

 

I changed the name of my config.sup and config.pro so I know they aren't being loaded. I also changed the name of the .dtl file being loaded so I know no drawing setup is being loaded other than Creo default items.

 

The attached file zclip shows the assembly with the original created section. What I'm trying to show in the drawing section view is just the hss and clip angle. I don't want to see the double tee leg beyond the clip angle. That is why I'm using z-clipping.

 

The attached file zclip1 results in hatching working with z-clipping turned on. But the z-clipping datum plane that I selected is all the way to the left and effectively isn't z-clipping anything.

 

The attached file zclip2 results in hatching not working but with z-clipping the way I want it. That is, z-clipping datum plane that I selected is between the clip angle and the double tee leg. When I do this combination the hatching disappears. I created the datum plane to make sure there wasn't any issue with what I selected.

 

What is going on is if the z-clipping depth is within a part, hatching isn't shown for that part. This can be seen in the attached file zclip3. I changed the section to go through both the hss and the clip angle. You can see where the z-clip depth was selected (datum plane between the clip angle and double tee leg). It was selected so it goes through the hss but is outside of the clip angle. As a result the hss isn't hatched but the clip angle is with z-clipping on.

 

Maybe all of this is that it isn't working the way I think it should. But I've always learned that the hatching should be shown on the parts where the section goes through. Which would mean that the hss and clip angle should both be hatched in zclip3.

 

I'm going to keep playing with this to try to better understand what is going on. I've seen this exact thing on other parts/assemblies that I've worked on.

 

Steve

 

 

 

 

Re: Cross hatching disappears w/ z-clipping


@sducotey-2 wrote:

Stephen thanks. Still not working the way I would suspect it to. I'll explain.

 

I changed the name of my config.sup and config.pro so I know they aren't being loaded. I also changed the name of the .dtl file being loaded so I know no drawing setup is being loaded other than Creo default items.

 

The attached file zclip shows the assembly with the original created section. What I'm trying to show in the drawing section view is just the hss and clip angle. I don't want to see the double tee leg beyond the clip angle. That is why I'm using z-clipping.

 

The attached file zclip1 results in hatching working with z-clipping turned on. But the z-clipping datum plane that I selected is all the way to the left and effectively isn't z-clipping anything.

 

The attached file zclip2 results in hatching not working but with z-clipping the way I want it. That is, z-clipping datum plane that I selected is between the clip angle and the double tee leg. When I do this combination the hatching disappears. I created the datum plane to make sure there wasn't any issue with what I selected.

 

What is going on is if the z-clipping depth is within a part, hatching isn't shown for that part. This can be seen in the attached file zclip3. I changed the section to go through both the hss and the clip angle. You can see where the z-clip depth was selected (datum plane between the clip angle and double tee leg). It was selected so it goes through the hss but is outside of the clip angle. As a result the hss isn't hatched but the clip angle is with z-clipping on.

 

Maybe all of this is that it isn't working the way I think it should. But I've always learned that the hatching should be shown on the parts where the section goes through. Which would mean that the hss and clip angle should both be hatched in zclip3.

 

I'm going to keep playing with this to try to better understand what is going on. I've seen this exact thing on other parts/assemblies that I've worked on.

 

Steve


Hi,

I tried to reproduce your problem in Creo 4.0 M120 ... see uploaded files. It seems to me that Creo works "as expected". (... I'm not sure if I understood your description correctly.)


Martin Hanák

Re: Cross hatching disappears w/ z-clipping

Martin,

 

Your files work as expected.

 

On my HSS part, when I change the Xhatch on the drawing from a .pat to a .xch the hatch shows up on the HSS. I changed the scale of the .pat hatch so it isn't a scaling issue.

 

What is odd is the clip angle is a .pat hatch and it works just fine.

 

Thanks 

Steve

Re: Cross hatching disappears w/ z-clipping

Your config test was valid.

Your .dtl test was not valid. The .dtl doesn't "load" every from the file when you open a drawing, it only loads when a new drawing is created. You have to open the settings on the specific drawing you are working on and change the settings in that drawing, that's why it's not easy to test.

 

What Creo are you running? Can you upload the models and drawing for testing? Or make simple test models/drawing to upload that has the same problem?

 

When I z-clip, it seems to keep all the x-hatch as expected even though I am sectioning through the parts that are clipped.

StephenWilliams_0-1595849907310.png

 


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)

Re: Cross hatching disappears w/ z-clipping

I'll create some simple parts and try to duplicate what I'm seeing. If it doesn't work as expected I'll upload them. Today is a crazy day for me so this will be tomorrow.

 

I'm using Creo 6.0

 

I saw some things yesterday after I posted that makes me think it is something with that HSS part.

 

Steve

Re: Cross hatching disappears w/ z-clipping

I just re-created new parts, assembly, and drawing to see if I could duplicate the issue. Unfortunately the problem still exists and is not fixed.

 

Attached is a zip file with the Creo 6.0.

 

If somebody can use these files please see if you have the same issue.

 

Steve

Re: Cross hatching disappears w/ z-clipping

On my HSS part, when I change the Xhatch on the drawing from a .pat to a .xch the hatch shows up on the HSS. I changed the scale of the .pat hatch so it isn't a scaling issue.

 

What is odd is the clip angle is a .pat hatch and it works just fine.

 

Steve

Re: Cross hatching disappears w/ z-clipping

Unfortunately I don't have access to Creo 6 without begging and pleading and that is no guarantee.

Hopefully someone will be able to open your files and see if they find any issues.


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)

Re: Cross hatching disappears w/ z-clipping


@sducotey-2 wrote:

I just re-created new parts, assembly, and drawing to see if I could duplicate the issue. Unfortunately the problem still exists and is not fixed.

 

Attached is a zip file with the Creo 6.0.

 

If somebody can use these files please see if you have the same issue.

 

Steve


Hi,

I worked with your files for some time. I can confirm that the problem is related to test_hss.prt.

I replaced this model (in assembly) with new one created from the scratch and then I was not able to reproduce the problem.

Unfortunatelly I can't figure out what's causing the problem. You can open Case at PTC Support and send them your test files for investigation.


Martin Hanák

Re: Cross hatching disappears w/ z-clipping

THANK YOU

Re: Cross hatching disappears w/ z-clipping

I did submit a PTC Support Case and they haven't determined what was causing the PAT hatch problem.

 

I just discovered that if I use a datum point to set the z-clipping depth (instead of a datum plane) the PAT hatch does show and fixes the problem.

 

Because of this, it almost makes you think the original datum plane that I was using for z-clipping wasn't parallel to the view plane. But the z-clipping datum plane was parallel because it was created using an offset.

 

I'm happy. I now have a work-around.

View solution in original post

Re: Cross hatching disappears w/ z-clipping

Using a point didn't fix the problem after all. The input allows you to select a point but when you close the dialog box it looses the point reference is it isn't z-clipping.

 

PTC is working on this.

Announcements