cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Export only visible parts from an assembly?

hnyström
1-Newbie

Export only visible parts from an assembly?

Is there an easy way of exporting only visible parts from an assembly? I received an assembly with a lot of subassemblies with a lot of subassemblies with some hidden parts. I will take me a lot of time to find every hidden part in every sub-sub-subassembly and exclude them individually in the STEP export dialog.

1 ACCEPTED SOLUTION

Accepted Solutions
TomU
23-Emerald III
(To:hnyström)

Assuming you're using Creo Parametric, you can add the config option intf_out_blanked_entities no.  With this set to 'no' only the items that are visible on the screen will be exported.

View solution in original post

11 REPLIES 11
TomU
23-Emerald III
(To:hnyström)

Assuming you're using Creo Parametric, you can add the config option intf_out_blanked_entities no.  With this set to 'no' only the items that are visible on the screen will be exported.

hnyström
1-Newbie
(To:TomU)

Thanks, worked like a charm.

@PTC, why don't you add a small checker box in the export dialog with this option? It is not so intuitive to have this option hidden (in the very unintuitive Configuration Editor).

I did not find this "intf_out_blanked_entities" in creo 4. Please help


@TomU wrote:

Assuming you're using Creo Parametric, you can add the config option intf_out_blanked_entities no.  With this set to 'no' only the items that are visible on the screen will be exported.


 

TomU
23-Emerald III
(To:rohitsharma)

@rohitsharma

One of the options which can help.

when saving as step, select "Customize export" Ok............. On export dialog box, Select exclude content for Hidden Items layer. I think this will help. 

Yes. it should be work.

 

Thanks a lot...

nareng
1-Newbie
(To:TomU)

Yes it works well. 

Thanks for this suggestion.

 

Regards,

Narendra Gupta

andrehj
5-Regular Member
(To:TomU)

I have a similar problem, but with parts. The stepfile includes many surfaces that are hidden in the part, and should not be exported.

However, the option to exclude these hidden surfaces is greyed out:

andrehj_0-1614678389676.png

How can I exclude these hidden surfaces from my STEP-export?

Looking at your settings I found that selecting Annotations is what is greying out Hidden entities.  If you don't need to export the annotations, deselect Annotations.

 

I don't know the thought behind this limitation.  Maybe because annotations are typically hidden on a layer.


There is always more to learn in Creo.
andrehj
5-Regular Member
(To:kdirth)

Thanks! The annotations were the problem indeed.

I agree with you, no idea why PTC made this choice. In our case we do want to have the annotations (geometric tolerances etc) in the STP file, but we do not want the hidden features....

For this specific case leaving the annotations out was acceptable.

You can Enable the Annotations and Disable the Hidden Entities by using an export profile.

 

Then edit the .dep_step profile file and set the Hidden Enitites to zero:

            <profile_options_xar__ENTRY id_="Hidden entities" pointer="TRUE">
                <value___PO__b__PC__>0</value___PO__b__PC__>

 

 

Announcements