cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can Bookmark boards, posts or articles that you'd like to access again easily! X

Model targets

tdevasagayam
5-Regular Member

Model targets

HI, is there any chance to use Vuforia model target option in Thingworx Studio

1 ACCEPTED SOLUTION

Accepted Solutions
tdevasagayam
5-Regular Member
(To:dupatel)

Today we got the option to create model targets . Need some examples and help files to use the option effectively.

View solution in original post

15 REPLIES 15

Hello, Thadeus.

I'm locating a resource in the ThingWorx Studio team who can help you with this.

Thank you,

-- Craig A.

tdevasagayam
5-Regular Member
(To:CRArko)

Is there any update?

Regards,

Thadeus.D

Is there any update on this? 4 months later and I am looking for this too...

dupatel
19-Tanzanite
(To:tdevasagayam)

Thadeus Devasagayamhmckee​: Tracking an object based on its 3D model is something Work in Progress and we anticipate releasing this capability sometime in the first quarter of 2018.

-Durgesh

tdevasagayam
5-Regular Member
(To:dupatel)

Today we got the option to create model targets . Need some examples and help files to use the option effectively.

mwassmann
5-Regular Member
(To:tdevasagayam)

you can try it out - what examples and help files are needed ?

Martin

tdevasagayam
5-Regular Member
(To:mwassmann)

I am trying now. Need some more time to locate the physical component. Probably another few more days.

Regards,

Thadeus.D

I did a quick test with an existing project, and it was pretty easy to replace the original thingmark with a model target. Scanning is a little on the futzy side, it takes a steady hand and a little time to get it to lock on, but once it does it works pretty slick.

On my Android phone, I'm having an issue with the experience displaying upside down when using a model target. I think this might be related to a quirk of the camera on my phone (Nexus 5x), because I've had a similar problem with general camera apps on this phone. Strangely, it doesn't seem to affect regular thingmark-based experiences. But it works very nicely on iOS 11 (iPad pro).

For anyone who's interested, here's the procedure I used:

In Thingworx Studio:

1) Open an experience that you want to switch to model-based tracking

2) Remove any existing thingmark in the experience, and set "thingmark association" to "none" in Experiences window

3) In the 3D Home screen, add a modelTarget widget to your model

4) In "Model Target Details" on the right, there will be a rectangle labeled "Detect Position", initially with a gray X in it. Click there.

5) Set the angle from which the user will scan the object to initiate tracking (usually the front), and click Save

6) Save and Publish the experience

In your Thingworx View app:

1) Open the app, tap the library icon (like a stack of cards)

2) Switch to the library view (icon looks like books on a shelf)

3) Find the experience with the title matching what you just published.

    a) In iOS, I could just tap on that title directly to start the experience

    b) In Android, I had to create a bookmark first, and then switch to the bookmarks view and select it there

4) You should now see a white outline of your model. Point the camera at the real object so that it matches the white outline as closely as possible. This will take a bit of adjusting, both distance and angle, to get it right. Once you get the right angle and distance for a good match, you'll need to hold it steady for a few seconds. When it acquires the tracking, your virtual model should appear in the experience.

5) From here you should be in good shape, ready to play any sequences or any other kinds of interactions you've defined for your experience. You should be able to move around the physical object (keeping it in the camera view) and have the experience maintain the tracking on it.

tdevasagayam
5-Regular Member
(To:ClayHelberg)

To publish the experience by using model targets, experience server should be 8.1.3 or later.

Yes, that's right. Also make sure your Thingworx View app is updated!

Hi Clay,

I have followed the procedure given by you regarding Model tracking. However, there seems to be an error in publishing the experience. I can confirm that ThingWorx Studio version is 8.1.3 . Can you help me in understanding if I need to do anything extra to publish the experience properly.

Thanks

Hi Sanjeev--

It's hard to say what might have gone wrong without knowing more about the error you got trying to publish. You might find some useful information in the Thingworx Studio log. (You can access it from the Thingworx Studio startup window--the one from the application, not the one in your browser. Click the "View Logs" link.)

--Clay

Hi Sanjeev--

I just noticed an announcement on the partner community blog about an outage on hosted trials of Thingworx for a scheduled upgrade. It's possible that you had the unfortunate timing of trying to publish during this outage. Maybe try again and see if it goes better now that the outage is resolved?

--Clay

Hello,

 

Thank you for that post, it really helped me out with figuring out how to use model targets. 

The thing is, it worked for me just one time. I am using an iOS device with Thingworx Version 8.2.1. It worked using the steps you have explained, now its not working anymore. I tried creating a new project a followed the same steps. It doesnt work anymore for some reason. 

 

But when it did work, the tracking was very good. Any ideas on what can be done? The only change I did was to add a 3D label to the project.

Announcements