cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

Cosmetic Thread in drawing

JG_10559632
5-Regular Member

Cosmetic Thread in drawing

Hi all, my cosmetic threads in my drawings are displaying through the part on a section view.
How can I get it to where the vertical lines are not showing?

 

JG_10559632_0-1674482172997.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
kdirth
20-Turquoise
(To:JG_10559632)

The display of the horizontal and vertical lines cannot be controlled independently in the view properties.  You will need to use Edge Display to either hide the horizontal lines or show the vertical lines.


There is always more to learn in Creo.

View solution in original post

9 REPLIES 9

Cosmetic threads are represented by surfaces in the part models. You need to filter the quilts in the drawing view.

 

Try implementing this in your drawing:

https://www.ptc.com/en/support/article/CS27579

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric
JG_10559632
5-Regular Member
(To:tbraxton)

Thank you! I will try this

StephenW
23-Emerald II
(To:JG_10559632)

If you are showing hidden lines and you want to see the thread and you are completely set on using cosmetic threads, your options are limited. In the drawing setup under File - prepare-drawing properties - detail options and look for Thread_standard and try std_ansi_imp

It reduces the amount of the vertical line. You can try the other options  and regen or repaint after each change.

 

When frustrated, I have erased the cosmetic and used a sketch in the model to show how I wanted it to show.

JG_10559632
5-Regular Member
(To:StephenW)

Yes I usually just use a sketch as well, but a colleague of mine insists on using the cosmetic thread. So I am trying to figure this out for him.
I will try these steps! Thank you!

msmith
14-Alexandrite
(To:JG_10559632)

Please try these settings documented in article CS367415:

 

  1. Create/ Redefine cross-section in the Part/Assembly from View tab and then the Section ribbon and Model tab > Include quiltsInclude_quilts
  2. In the Drawing, set detail option hlr_for_threads to no
JG_10559632
5-Regular Member
(To:msmith)

Hi I did this but it removes the whole comsetic completely.

JG_10559632_0-1674510512826.png



I still want these vertical cosmetics. Just not the horizontal ones.

kdirth
20-Turquoise
(To:JG_10559632)

The display of the horizontal and vertical lines cannot be controlled independently in the view properties.  You will need to use Edge Display to either hide the horizontal lines or show the vertical lines.


There is always more to learn in Creo.
JG_10559632
5-Regular Member
(To:msmith)

JG_10559632_1-1674510850061.png

Also, whenever I change the Hidden line removal for quilts to yes, it completely erases the cosmetic thread.

msmith
14-Alexandrite
(To:JG_10559632)

I'm not sure if I follow. Can you attach a copy of the drawing and its model(s) with a clear image of which lines you want shown and which ones you want hidden?

Top Tags