cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to community-mailer@ptc.com. Learn more.

It takes a long time to retrieve large assembly file in Creo 7

rusmansait
6-Contributor

It takes a long time to retrieve large assembly file in Creo 7

I am using Creo Parametric Release 7.0 and Datecode7.0.7.0

It takes a long time to retrieve large assembly file. When moving (Pan/Zoom/Rotate) large assemblies in graphics, movement is slow/sluggish

9 REPLIES 9
StephenW
23-Emerald II
(To:rusmansait)

What graphics card are you using?

Do you have any graphics options turned on in the config.pro, such as graphics win32_gdi (which is bad for graphics performance but helps for testing of graphics card problems)

 

rusmansait
6-Contributor
(To:StephenW)

Having NVIDIA Quadro K2000 and there is no setting for graphics on my config

 

StephenW
23-Emerald II
(To:rusmansait)

Do you have any thing selected during Pan/Zoom/Rotate? I don't think it is as much of a problem as it used to be, but having components selected during moving would degrade graphics performance.

Are you Pan/Zoom/Rotate in wireframe or shaded? Rotating while shaded will be much better than when in wireframe or hidden line.

 

You can test to see if it one of your options that is causing problems by temporarily "renaming" all your config.pro/config.sup/creo_parametric_customization.ui files and restart creo. If the problem goes away, then it is one of your config settings that is causing the issue.

Quantify "large assembly". How many components are in the assembly?

 

Confirm that you have an Nvidia graphics driver that is ISV certified for Creo use.

 

Are you aware of simplified reps? Consider saving components with all features set to read only.

Set the display to wireframe, does the performance of spin/pan.zoom change noticeably?

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric
rusmansait
6-Contributor
(To:tbraxton)

27000 components in my assembly. I am using simplified reps. but still performance is low

I would expect very sluggish performance with a  Quadro K2000 GPU for this.

 

I would strongly suggest implementing some top down design workflows that avoid the requirement to have an assembly with 27,000 components in session to work on designs. Set all components you are not modifying to read only for all features would be a starting point while you work out the workflow and structure of the CAD data to manage design intent.

 

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric
remy
21-Topaz I
(To:rusmansait)

Some large assembly is causing delay in all aspects and this is unusual.
Can you confirm the issue happens when the assembly is opened from the hard drive? or does it happen exclusively connected with Windchill?

Are these articles of some help at all?

 

rusmansait
6-Contributor
(To:remy)

Our Creo is connected with Windchill. but result is same for when not connected to Windchill

remy
21-Topaz I
(To:rusmansait)

The issue persists offline and this mean that the loss of performance is attributed to the graphics performance of Creo. 

did you give a try to the options of the above articles?