cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Want the oppurtunity to discuss enhancements to PTC products? Join a working group! X

I am having issues with Tangent edges display style

lfuller
1-Newbie

I am having issues with Tangent edges display style

Changing this option works fine in Wireframe, No Hidden line, and Hidden line modes. But the tangent edges always appear as solid lines in the Shaded with edges mode, which is the mode I'm working in. Can anyone help?

1 ACCEPTED SOLUTION

Accepted Solutions

Lane,

according to https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS140509 ... starting from Creo Parametric 2.0 M070 you can turn on/off tangent edges in Shaded with edges mode (only) using config.pro option:

shade_with_edge_tangent (yes*/no)


In Shaded with edges mode you cannot set tangent edge display to Phantom (for example), as you can in Hidden mode. You can contact PTC Support, if you want to confirm this information.

Martin Hanak


Martin Hanák

View solution in original post

4 REPLIES 4

You might get some improvement with graphic settings but for the most part, the graphics are quite imprecise, where the math behind them is precise.

A lot of the graphics will improve when you zoom into a feature, but if the feature continues far outside the zoom state, it will not improve within the current zoom state.

This really should be addressed in the graphics portion of the software so that all geometry in the current zoom state is smoothed even when significant segments lie outside the screen boundary.  I don't know that it doesn't do this to some extent, but in general, it is insufficient when very detailed work is required.

Lane,

according to https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS140509 ... starting from Creo Parametric 2.0 M070 you can turn on/off tangent edges in Shaded with edges mode (only) using config.pro option:

shade_with_edge_tangent (yes*/no)


In Shaded with edges mode you cannot set tangent edge display to Phantom (for example), as you can in Hidden mode. You can contact PTC Support, if you want to confirm this information.

Martin Hanak


Martin Hanák

Martin,

That is exactly what I need. Thank you so much for your help!

Great tip, Martin.  Works great in Creo 3.0 too.

Sorry I misread your post, Lane.

Announcements
Business Continuity with Creo: Learn more about it here.

Top Tags