cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Connecting the robot and KEPSereverEX

Highlighted
Level 7

Connecting the robot and KEPSereverEX

Hello,

How to properly configure the Fanuc LR Mate and the KEPServerEX for data exchange? I wrote IP into the column ID, is this correct? Also I chose the driver under my brand. What else do I need to do?

11 REPLIES 11

Re: Connecting the robot and KEPSereverEX

Greetings @Kate,

 

Thanks for posting your question. There are a few additional steps to follow in this setup.

 

1. Are you interfacing with a 30i controller to operate the LR Mate robot? Bear in mind, you will be connecting with the PMC, and your Device Model selection in KEPServerEX will reflect the model of the PMC. If you are unsure which to choose, use the "Open" Model selection.

 

2. Communication between the Focas 1 or Focas 2 CNC / PMC data window control libraries on the Device and  the KEPServerEX Fanuc Focas Ethernet Driver, requires the installation of the Fanuc Focas Libraries on the KEPServerEX PC. For more information on this, see either of the following:

 

Article - CS281557 What libraries are required when using the Fanuc Focas Ethernet Driver in KEPServ...

 

The External Dependencies section of the Fanuc Focas Ethernet Driver help manual.

 

3. You will need to create Tags in the KEPServerEX Device using the addressing conventions described for the Model type you selected (Power Mate i). For more information on the Address Type / Ranges, see the Power Mate i section of the Fanuc Focas Ethernet Driver help manual. Or, refer to the Open protocol section of that same manual if this is the Device Model selection you end up going with.

 

4. After following the steps above and adding your tags, launch the OPC Quick Client to test the connection. Do you see Values updating, with a "Good" Quality, for these Tags?

 

 

Best regards,

Steven M

 

Re: Connecting the robot and KEPSereverEX

I have such errors in the event log. Tell me, please, how do I install libraries and with what devices?

Re: Connecting the robot and KEPSereverEX

And is the connection error now only in the problem with the installation of libraries?

Re: Connecting the robot and KEPSereverEX

Greetings @Kate,

 

Refer to the links in the first post on instructions for obtaining and installing the library files. You will not be able to form this connection without those files in place on the KEPServerEX PC.

 

After acquiring and installing the libraries, please let us know how it goes, and the status of this connection.

 

 

Best regards,

Steven M

Re: Connecting the robot and KEPSereverEX

Sorry, did not see one of your links.
I have done all the steps, the robot's IP responds through the command line, the Fanus FOCAS libraries also work (checked through another application using their CNCnetPDM), the status of the robot is displayed and other information. Everything is still in KepserverEx. What am I doing wrong?

Re: Connecting the robot and KEPSereverEX

Hi @Kate,

 

Thank you for confirming. I have a few more recommendations to go through.

 

1. Since the versioning of the FWLIB files has been an issue for users in the past, verify you have these two files:

  • FWLIB32.DLL (version 1.12.0.2 or later)
  • FWLIBE1.DLL (version 1.6.0.2 or later)

Also verify they are located in the System directory appropriate for the Windows version you are using:

  • 32-bit Windows operating systems: C:\Windows\System32
  • 64-bit Windows operating systems: C:\Windows\SysWOW64

 

2. In the KEPServerEX Event Log, are you still seeing the same error you reported earlier (FWLIB error: 65520)?

This error is being reported by the Fanuc Library, and is likely related to a socket error. To account for this, consider these points:

a. What is the port you are using to connect the CNCnetPDM application? The default in KEPServerEX is 8193. To change this, open the Device Properties > Communication Parameters properties group > edit the TCP/IP Port field.

b. Are you testing the connecting KEPServerEX concurrently with the CNCnetPDM application? This would likely jeopardize the single port, and only one application would be able to succeed at a time.

 

 

If any of the above suggestions do not work, please let us know. We will want to discuss further options for analyzing the socket connection, with tools like Telnet and Wireshark.

 

 

Best regards,

Steven M

Re: Connecting the robot and KEPSereverEX

Hello,

 

Sorry for the inconvenience, but I really do not understand what the problem is. And let me tell you everything from the very beginning, maybe I made a mistake during the creation.


I installed the libraries in SysWOW64, the version of the products Fwlib32 5.8.0.1 and Fwlibe1 3.8.0.1. (although in fact there are other libraries from Fanus FOCAS). Having installed KEPServerEx, I created a channel with the driver Fanuc FOCAS Ethernett. Then I created the Power Mate I model (I use the robot LR Mate 200iD / 4s with the R-30ib Mate controller), I wrote the IP address of the robot in the ID, the port left the default 8193 (like the other settings). Then I created several tags with different types of addresses, using the table from the manual. When I started Quick Client, there were errors that I addressed to you and applied, because the manual did not have error code 65520. Do I still have to do something extra all these steps?
When you wrote about a possible problem with libraries, I installed the CNCNetPDM using Fanus FOCAS to make sure that the libraries I purchased were working. However, there according to the manual for the installation, all libraries were placed in the installation folder of this program, but they were also stored in SysWOW64. When I was able to connect and get basic information about the robot, it seemed to me that the problem was not in the libraries, but in the settings of KepServer, but of course I could be wrong.
As for your previous message.
KEPServerEx was tested on port 8193, but CNCNetPDM was not started at that time. I changed the port (8190) on your recommendation, but the changes in the work did not happen either. I returned it back to 8193, and after restarting the computer without starting CNCNetPDM, nothing has changed. When I launched the Quick Client, an error with code 65520 appeared again.
My task: I need to establish a connection with the robot to subsequently connect it to the ThingWorx platform and manage it from there. Are there any other ways to do this (maybe using other software?)

 

Thank you for giving me so much time. I will be happy with any help.

Re: Connecting the robot and KEPSereverEX

And one more question, is it necessary to download Fanus libraries in the Dr folder? If I do this, I get an error Unable to load driver DLL 'C: \ Program Files (x86) \ Kepware \ KEPServerEX 6 \ drivers \ fwlibe1.dll'. Reason: Version mismatch. So, is there something wrong with the dll file?

Re: Connecting the robot and KEPSereverEX

Greetings @Kate,

 

Thank you for explaining your setup and steps followed. You will only want to locate those dll files in the SysWOW64 directory, not the KEPServerEX directory you mentioned.

 

I do suspect there is a problem with the versions of the files you are using. These are the files you will need:

FWLIB32.DLL (version 1.12.0.2)

FWLIBE1.DLL (version 1.6.0.2)

Note, the filenames are case sensitive. (You will want to locate the file that is FWLIB32.DLL, for example).

 

Once you have secured those files in the SysWOW directory, it may also be necessary to reboot the PC. Let me know how this goes. If you are still having trouble, we may want to discuss an offline troubleshooting session.

 

 

Best regards,

Steven M