cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Control Advisor App - Kepware server added but not visible

SOLVED
Highlighted
Level 6

Control Advisor App - Kepware server added but not visible

Hello,

 

I have an issue to view the connected servers on the Manuf App Control Advisor.

 

Versions : 

  • Tomcat 8.5.23
  • Postgres 9.4.16
  • TWX 8.2.1
  • Manuf Apps 8.1.2 Extension
  • KepServerEX-6.4.321

Everything is installed and run smoothly.

 

My Kepware server is well connected to TWX : 

  • Kepware project well set to connect to TWX
  • Log Kepware : Information ThingWorx Native Interface Connected to ThingWorx. | Platform: <myserver>/Thingworx/WS, Thing name: 'KepwareServerTraining-GW'.
  • Thing[KepwareServerTraining] has the property "isConnected" at "true", so the connection is well established
  • Thing[KepwareServerTraining-GW] : has the property "ActiveTagCount" at "41" which is the number of tags in my kepware, so the data are well gathered 

But the problem I have is that in my App Control Advisor, the list of Servers is empy. Even when I add new server the created server is not displayed. If i try to create the server again in the Control Advisor App a message tells me that the server already exists, which is normal.

 

Anybody knows why my Kepware Server is not visible in my Connected Server of Control Advisor App ? 

See screenshots to have more details.

 

Thank you,

Geoffrey

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Control Advisor App - Kepware server added but not visible

Hi Geoffrey.

 

I see that you are running ThingWorx Manufacturing Apps 8.1.2 on ThingWorx 8.2.1.  This unfortunately, is not a supported configuration and is prone to issues.  Please update ThingWorx Manufacturing Apps to the 8.2 version and reassess the issue.

 

You can find the Manufacturing Apps 8.2 extension the on the PTC Support Download page:

 

MfgDownloadPg.png

2 REPLIES 2

Re: Control Advisor App - Kepware server added but not visible

Hi Geoffrey.

 

I see that you are running ThingWorx Manufacturing Apps 8.1.2 on ThingWorx 8.2.1.  This unfortunately, is not a supported configuration and is prone to issues.  Please update ThingWorx Manufacturing Apps to the 8.2 version and reassess the issue.

 

You can find the Manufacturing Apps 8.2 extension the on the PTC Support Download page:

 

MfgDownloadPg.png

Re: Control Advisor App - Kepware server added but not visible

It works with the good 8.2 version, thank you !

For information I tried to install the 8.2 version on the top of the 8.1, I saw the server but some errors were happening. I reverted to a snapshot without 8.1 installed and installed the 8.2, everything works perfectly.

 

Thanks a lot for you help.

 

Geoffrey