cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

automatically show full UI from Mini toolbar command

ThomasKirkman
16-Pearl

automatically show full UI from Mini toolbar command

Currently, when a command is started from the mini toolbar, the full UI is not shown. Pressing shift+space will open up the full UI for the command. Is there a way to automatically show the full UI without having to hit shift+space? More often than not, I need the full ui open.

Creo Element\Direct Modeling 20.6.0.0.0
9 REPLIES 9

Hi Tom,
the behavior has also annoyed me a little and that's why I asked the Support.

Description:
Setting required to automatically open the Dialog Box of a command, when selecting it using the Command Mini Toolbar (CMT)
How to specify, that the parameter dialog of a command automatically opens up when selecting the command in the CMT


Resolution:
Reported to Product Management as to enhancement request
Workaround:
Commands exist to enable or disable the automatic command dialog box opening:

o Enable: (setq ui::*ui-on-request-enabled* nil)
Attention, the switch does not work on every menu!
As you drag, for example, do not. But when filleting or chamfering. (***)

o Disable: (setq ui::*ui-on-request-enabled* t)
· This switch can be Entered into the Modeling commandline, added to a file sd_customize

or create on-off buttons.

(***) I have tested in 18.1 and so far I have not found any menu that did not open

Best regards

Friedhelm

ps. what is going on at cocreateusers.org
>>Account for domain cocreateusers.org has been suspended

seems to be solved

Nachricht geändert durch FriedhelmK: edit: seems to be solved

(Please write info in your Signature) Sysinfo: I use Creo Elements Direct /Drafting, /Modeling and /Modeling Express 8.0 ( formerly CoCreate- SolidDesigner and Drafting or ME10 )

The attached command checks the current state of (ui::*ui-on-request-enabled*) and toggles it to the opposite.

Creo Element\Direct Modeling 20.6.0.0.0

Hello Tom,

verry good this toogle button.

Your original question is answered?

Now i have a question.

Since v18 the imported 2d elements of the working planes can be represented in their original colors and line types .

If this is set to ON you can not work good with the elements and you have to switch to OFF.

Currently I have two buttons and wanted to make one as in your example but unfortunately it does not work.

Because I'm not good in Lisp, I want to ask here in the forum where the error is.

(in-package :OI_Tools)
(use-package :oli)

;;define toggle_line_type_and_color
(defun toggle_line_type_and_color ()
;;check to see if the function is available on request (t) if so make it default, else make it true.
(if (eql (set-default-show-setting :workplanes_2dgeo_color t))
(setq (set-default-show-setting :workplanes_2dgeo_color nil)
(set-default-show-setting :workplanes_2dgeo_line_type nil)
(set-show-settings-to-default (oli::sd-inq-current-vp)))
(setq (set-default-show-setting :workplanes_2dgeo_color t)
(set-default-show-setting :workplanes_2dgeo_line_type t)
(set-show-settings-to-default (oli::sd-inq-current-vp)))
))


;; 1.Button for show ON
;;(set-default-show-setting :workplanes_2dgeo_color t)
;;(set-default-show-setting :workplanes_2dgeo_line_type t)
;;(set-show-settings-to-default (oli::sd-inq-current-vp))
;; 2.Button for show OFF
;;(set-default-show-setting :workplanes_2dgeo_color nil)
;;(set-default-show-setting :workplanes_2dgeo_line_type nil)
;;(set-show-settings-to-default (oli::sd-inq-current-vp))

(Please write info in your Signature) Sysinfo: I use Creo Elements Direct /Drafting, /Modeling and /Modeling Express 8.0 ( formerly CoCreate- SolidDesigner and Drafting or ME10 )

Has anyone been able to get this command to work in v20.2? I would like the full UI to come up in Modeling during commands however it does not. I tried the (setq ui::*ui-on-request-enabled* nil) lisp command however it is not working for me.

Hi Dan
I've been doing this for some time now:
File - Settings - UI ... - and set "Show OK and Cancel buttons:" to None

This tip came "then" from PeterKehoe

Have a look at
https://community.ptc.com/t5/Creo-Parametric-Ideas/Add-the-option-to-always-have-the-dialog-box-for-an-operation/idc-p/469329#M2805

 

LINK 

(Please write info in your Signature) Sysinfo: I use Creo Elements Direct /Drafting, /Modeling and /Modeling Express 8.0 ( formerly CoCreate- SolidDesigner and Drafting or ME10 )

Thanks for your reply @FriedhelmK 

 

Unfortunately this does not work for me in v20.2.1. I changed to display None however the little green triangle still comes up with every command and I have to click on it to display the full dialog.

Do you have the same experience in V20.0?
I can see no change there.
I have not yet installed V20.2.

So I can't try it.

(Please write info in your Signature) Sysinfo: I use Creo Elements Direct /Drafting, /Modeling and /Modeling Express 8.0 ( formerly CoCreate- SolidDesigner and Drafting or ME10 )

Sorry I don't recall if the command worked for my in V20.0 or not.

Hi Dan,
just installed 20.2.1.0.
For me, the automatic opening of the individual menus when selecting the various commands works as usual.
Sometimes it takes a while for them to open.
I added some screenshots to show how I do it.

First click on the command in the mini toolbar.
If you pull directly on the Polstar then the 1st command Top Left is selected and the menu does not come but the green triangle.

 

automatically_show-full_UI_from_Minitoolbar_command.jpg

(Please write info in your Signature) Sysinfo: I use Creo Elements Direct /Drafting, /Modeling and /Modeling Express 8.0 ( formerly CoCreate- SolidDesigner and Drafting or ME10 )
Top Tags