cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Chalk button problems in upgraded experiences

SOLVED
Highlighted
Level 10

Chalk button problems in upgraded experiences

Hi All,

 

I found a problem with the new Chalk widget not working properly when adding it in to projects that were created in older versions of Studio.

 

The problem is that the button appears as a solid green square in the preview and in the published experience rather than as the green square with the Chalk icon as you see in the experience editor.

 

This only happens when I add the Chalk widget into existing experiences that were created in older versions of Studio.  If I create a new experience and add the Chalk widget, everything is fine.

 

 

Looking through the Studio log file and the browser console for the preview, I can see that it's missing the Chalk.svg file that should be in <project>dist\extensions\images.  I'm guessing that when the project gets built for the preview and publish, it doesn't copy over the images folder from <project>\extensions.

 

It looks like there's something wrong with my setup as a colleague doesn't have this issue.

 

Is anyone else seeing this problem?  @tmccombie Any reports of this from others?

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Chalk button problems in upgraded experiences

Hi All,

 

I have worked out what is causing the problem.  All of the experiences that I was testing were using a custom shader defined in a TML Text widget.  It's got nothing to do with an upgraded project.

 

To replicate the problem, just put a TML Text widget into the view and then preview the experience.  If I remove the TML Text widget, then the Chalk button shows fine.

 

I can work around this by changing my experience to remove the customer shader or creating a hyperlink formatted to look the same as the Chalk button via CSS, but it would be nice to get this fixed.

 

Cheers,

 

Allan

6 REPLIES

Re: Chalk button problems in upgraded experiences

@AllanThompson It appears to be something specific to your environment as I did tried couple of old project & adding chalk widget did not observed any issues.

 

Could you please confirm if this is happening with all your old project or is it one of ? Also, do you remember the old Studio version on which you build the project ?

 

-Durgesh

Re: Chalk button problems in upgraded experiences

Hi Durgesh,

 

As far as I can work our, it's happening on every project that I've created before 8.3.5.  If I open a project and I see the "upgrading project" message as it loads, then it will have the problem.

 

I tried creating a new project, adding in a Chalk widget and launching the preview, which worked fine. Then I got out of the project, copied the Home.json file from the old project over the top of the new project's json and then when in and previewed the experience and it had the problem.

 

When I look through the JSON for a new project, some of the container definitions look a bit different to the old format, but I would assume that everyone would have the same thing, so I"m not sure why I'm getting the problem.

 

I'll try removing Studio and re-installing it to see if anything changes.

Re: Chalk button problems in upgraded experiences

I can't reproduce this. I get the correct Chalk icon on upgraded projects.

Re: Chalk button problems in upgraded experiences

@AllanThompson I haven't seen this with any other users. Let me know if a reinstall doesn't fix it. 

Re: Chalk button problems in upgraded experiences

Hi All,

 

I have worked out what is causing the problem.  All of the experiences that I was testing were using a custom shader defined in a TML Text widget.  It's got nothing to do with an upgraded project.

 

To replicate the problem, just put a TML Text widget into the view and then preview the experience.  If I remove the TML Text widget, then the Chalk button shows fine.

 

I can work around this by changing my experience to remove the customer shader or creating a hyperlink formatted to look the same as the Chalk button via CSS, but it would be nice to get this fixed.

 

Cheers,

 

Allan

Re: Chalk button problems in upgraded experiences

@AllanThompson Thanks Allan for sharing details so it appears to be an issue with custom TML widget. We will raise a case on your behalf for fixing the issue in future releases.

 

Thanks,

Durgesh