cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Auto-refresh function not working in a popup

SB_9732186
9-Granite

Auto-refresh function not working in a popup

I have put a label in a mashup & data for that label is coming from a service. That service is being invoked by an auto-refresh function. It is working as expected when that mashup is run solely. But when I open that mashup from another mashup, using the navigation function, the auto-refresh doesn't seem to work at all.

1 ACCEPTED SOLUTION

Accepted Solutions
suverma
12-Amethyst
(To:SB_9732186)

Hi @SB_9732186 

 

Just found out that the fix for Auto-Refresh not working in a pop-up will be delivered in 9.1.3 too along with 9.2.0.

 

So if you want you can simply do a patch update to 9.1.3 than upgrading to 9.2.

View solution in original post

11 REPLIES 11
suverma
12-Amethyst
(To:SB_9732186)

Hi @SB_9732186 

 

I will try and replicate that. Can you please let me know your Thingworx version.

Thingworx version 9.1

I have a similar use case on ThingWorx 9.1 and auto refresh works fine there with Navigation - New window as well as pop up. I am not sure if this was reproducible on any older version but @suverma can try on your build itself.

 

 

 

Hi @mnarang ,

 

Can you please attach some screenshots of your setup, which consists of the bindings & other configurations.

 

Thanks.

I have created a small test for you and attaching all the entities.
Note:- you can observer that autorefresh is working absolutely fine by observing the service call in F12

Hi @mnarang ,

 

The auto-refresh & navigation widgets you have used are Legacy widgets. I was talking about the navigation & auto-refresh function which will probably replace those legacy widgets. 

 

Thanks.

suverma
12-Amethyst
(To:SB_9732186)

Hi @SB_9732186 

 

It does appear to be an issue as I am able to replicate the same on my end. Let me have an internal discussion upon this and confirm you if this a known bug or something which need to be reported.

 

Will keep you posted.

okay, understood. My use case was coming from an earlier version so that's why it is using legacy. But I or @suverma can try to do the same with functions as well. will update you

Hi @mnarang & @suverma 

 

I think @suverma has already replicated my use case & it doesn't seem to work.

I also got to know from one of my contacts that this bug has been already reported & will probably be rectified in TWX 9.2.0.

So till then the work around is to use the legacy widgets itself.

 

Thanks.

suverma
12-Amethyst
(To:SB_9732186)

Hi @SB_9732186 

 

Just found out that the fix for Auto-Refresh not working in a pop-up will be delivered in 9.1.3 too along with 9.2.0.

 

So if you want you can simply do a patch update to 9.1.3 than upgrading to 9.2.

slangley
23-Emerald II
(To:SB_9732186)

Hi @SB_9732186.

 

ThingWorx 9.1.3 was delivered last week.  Please check to see if this version resolves your issue.

 

Regards.

 

--Sharon

Announcements