cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Line Chart Padding Issue

psp316r
16-Pearl

Line Chart Padding Issue

Placed a Line Chart on the Mashup, as soon as Chart Plotted, the chart is not getting placed properly on the dashboard.
May be this is due to the Padding issue. The Line chart on the dashboard is something like this:

psp316r_0-1640471355328.png


 How Can Padding properly set for the Line Chart.
 
@paic @slangley @c_lowy @VladimirN 

Thanks,
Shashi

1 ACCEPTED SOLUTION

Accepted Solutions

The issue is solved by the CSS provided by @c_lowy .

ptcs-chart-line::part(chart-layout) {
padding: 0;
}
If there are 2 or more DataSources given to the Line chart,
1. Enable the Multiple Data source Visualization option in widget properties, and
2. Connect to the 2 or more Data Sources to chart widget again.
3. Select the X Axis as TimeStamp(in my case)

Thanks,
Shashi

View solution in original post

8 REPLIES 8
bchaudhary
14-Alexandrite
(To:psp316r)

Hi @psp316r , 

 

Kindly check the below attached article:

https://www.ptc.com/en/support/article/CS343992?posno=1&q=line%20chart%20padding&source=search

 

Revert back in case of further challenges. 

 

Regards

Bhawna

Hi @bchaudhary ,

tried the article, didn't help. The Picture in the issue posted is after trying out the article you have shared.

Thanks,
Shashi.

PEHOWE
16-Pearl
(To:psp316r)

@psp316r

 

Have you provided values for the properties "XAxisMaxmumValues", "XAxisMinimumValues", "YAxisMaximumValues" and "YAxisMinimumValues". These properties can be bound to services if the X Axis values change based on other issues.

 

Hope this helps.

 

psp316r
16-Pearl
(To:PEHOWE)

Hey Hi @PEHOWE 

Thanks for quick response, as per the use case the X and Y axis should be auto can't put min and max values.

Thanks,
Shashi

make the container fixed height

 

Hey Hi @GuruPrasad1 ,

Didn't get you, can you show a example ?

Thanks,
Shashi.

Hi Shashi,

Usually this happens when the container in which your are placing the chart is responsive, if you instead choose a fixed length and give a value say 500px this would appear better. This settings you can find in the layout tab am attching

 

GuruPrasad1_2-1640867377075.png

 

 

GuruPrasad1_0-1640867292113.png

 

Regards

Guruprasad S

 

The issue is solved by the CSS provided by @c_lowy .

ptcs-chart-line::part(chart-layout) {
padding: 0;
}
If there are 2 or more DataSources given to the Line chart,
1. Enable the Multiple Data source Visualization option in widget properties, and
2. Connect to the 2 or more Data Sources to chart widget again.
3. Select the X Axis as TimeStamp(in my case)

Thanks,
Shashi

Announcements