cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

RadioButton SelectedValue not set to default value at Mashup load

Highlighted
Level 1

RadioButton SelectedValue not set to default value at Mashup load

Hi,

I have a RadioButton with two states and I have set one of the states as default. When I start the Mashup the correct button is selected (blue) so I assume it's working.

However, the SelectedValue is set to undefined at startup instead of the default value. I have to manually click on the RadioButton to get some sensible value to the SelectedValue. Surely, it should be set to default by default? What is the use of the default value if it's not reflected in the SelectedValue?

Of course I can make a service that sets the value at startup but I should not need to do it. Is this a bug? Did I do something wrong?

-Risto

PS:

I'm using version 7.2.5-b56.

Tags (2)
5 REPLIES

Re: RadioButton SelectedValue not set to default value at Mashup load

Hi Risto Vaaraniemi​,

Could you please open a TS case with PTC to report this Bug. I am also able to reproduce it.

Thanks,

Ankit Gupta

Re: RadioButton SelectedValue not set to default value at Mashup load

Hi,

Sure. Just let me know what to do.

Thanks for confirming the case.

-Risto

Re: RadioButton SelectedValue not set to default value at Mashup load

Hi, Please open a TS case with PTC to report this Bug.

Re: RadioButton SelectedValue not set to default value at Mashup load

Hi,

It seems I don't have sufficient privileges to make a TS case (I suppose TS == Technical Support). When I go to https://support.ptc.com/ and click on "Contact Support" -> "Open a case with technical support" I get an error message complaining about my insufficient privileges.

My account here is completely unrelated to my account to ThingWorx platform I'm using. I'll try to contact the company who provides me access to the platform if they can open a case for me.

Thanks for the support so far. Should the platform provider company open a case for this, I'll let you know about it here.

-Risto

Re: RadioButton SelectedValue not set to default value at Mashup load