cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble trying to connect my first remote thing

Highlighted
Visitor

Trouble trying to connect my first remote thing

I'm working with the SteamSensor Example included with the C-SDK.  I have the client built, and I've created a thing with the same name. I know that the SteamSensor thing is connecting, as I see the isConnected and lastConnection properties change when the client runs.  I've bound a few of the properties to the Thing, but I'm not seeing any data values, and I'm seeing errors from the client.

image.png

 

Here is a sample of the client output.

 

[TRACE] 2018-09-04 10:09:33,764: subscribedPropsMgr_RetrievePersistedValues: Retrieving persisted values from file UNKNOWN
[ERROR] 2018-09-04 10:09:33,764: subscribedPropsMgr_UpdateSavedValues: spm->persistedValues not initialized
[TRACE] 2018-09-04 10:09:33,764: twSubscribedPropsMgr_PushProperties: Attempting to push queued properties
[TRACE] 2018-09-04 10:09:33,764: twInfoTableRow_CreateFromStream: Marker is empty. No more rows in stream
[TRACE] 2018-09-04 10:09:33,764: twInvokeUpdateSubscribedPropertyValues: Pushing all properties for SteamSensor.
[TRACE] 2018-09-04 10:09:33,764: twStream_AddBytes: adding 1 bytes would exceed the length of 256. Expanding stream.
[TRACE] 2018-09-04 10:09:33,764: twStream_AddBytes: adding 316 bytes would exceed the length of 256. Expanding stream.
[DEBUG] 2018-09-04 10:09:33,836: twWs_SendMessage: Sent 331 bytes using 1 frames.
[TRACE] 2018-09-04 10:09:33,836: twMessage_Send: Message with RequestId 104 sent successfully
[TRACE] 2018-09-04 10:09:33,938: twTlsClient_Read: Read: 2, Asked for: 2
[TRACE] 2018-09-04 10:09:33,938: twWs_Receive: Read 2 bytes into header buffer
[TRACE] 2018-09-04 10:09:33,938: twWs_Receive: Got Header: Body length = 89
[TRACE] 2018-09-04 10:09:33,938: twTlsClient_Read: Read: 89, Asked for: 89
[TRACE] 2018-09-04 10:09:33,938: twWs_Receive: Read 89 bytes into Frame buffer
[TRACE] 2018-09-04 10:09:33,938: twWs_Receive: Received Binary Message in Single Frame
[TRACE] 2018-09-04 10:09:33,938: msgHandlerOnBinaryMessage: Inserted message onto queue. ID: 104, Type: 2, Queue Total: 1
[TRACE] 2018-09-04 10:09:33,938: twMessageHandler_msgHandlerTask: Processing Incoming Message Queue, Queue Total: 1
[TRACE] 2018-09-04 10:09:33,938: twMessageHandler_msgHandlerTask: Removing Message ID: 104 from Incoming Messages Queue
[TRACE] 2018-09-04 10:09:33,938: twMessageHandler_msgHandlerTask: Received Binary Message ID: 104, Queue Total: 0
[TRACE] 2018-09-04 10:09:33,938: handleMessage: Received Response to Message ID: 104
[TRACE] 2018-09-04 10:09:33,938: handleMessage: Got response for message 104
[ERROR] 2018-09-04 10:09:33,938: twMessaging::handleMessage: Response ID 104 has code 160: Entity SteamSensor does not exist or is not yet associated with a Thing
[TRACE] 2018-09-04 10:09:33,938: handleMessage: Marked message 104 as received
[DEBUG] 2018-09-04 10:09:33,938: twMessage_Delete: Deleting RESPONSE Message: 104
[TRACE] 2018-09-04 10:09:33,938: twMessageHandler_GetCompletedResponseStruct: Found Message ID: 104
[TRACE] 2018-09-04 10:09:33,938: api:sendMessageBlocking: Received Response to Message 104. Code: 160
[DEBUG] 2018-09-04 10:09:33,938: twMessage_Delete: Deleting REQUEST Message: 104
[ERROR] 2018-09-04 10:09:33,938: twSubscribedPropsMgr_PushPropertyInfoList: Error pushing properties for SteamSensor. Error: 1110.
[ERROR] 2018-09-04 10:09:33,938: twSubscribedPropsMgr_PushProperties: error pushing or persisting property list, code: 1110

 

 

Any help or advice would be appreciated.

 

Thanks,

 

1 REPLY 1

Re: Trouble trying to connect my first remote thing

Hi @brentzki your RemoteThing SteamThing seems to be connected, if i check the isConnected value which is true and the date/time stamp for the last connection seems to 2018-09-04 10:33..  which is later than the logs you have pasted which are from 10:09:33

 

So to me it looks like the errors are from the time may be when the thing didn't exist? Do you not see any values after you refresh with the button shown in the Value column for the properties?

 

How does the Remote / Unbound monitoring looks like for the SteamSensor entity in the Monitoring section?