Skip to main content
1-Visitor
July 24, 2017
Solved

Error during Thingworx.war deploy on tomcat

  • July 24, 2017
  • 4 replies
  • 4248 views

Hi,

I get a Error during Thingworx.war deploy on tomcat

GRAVE [http-nio-8080-exec-9] org.apache.catalina.core.ApplicationContext.log HTMLManager: FAIL - Deploy Upload Failed, Exception: org.apache.tomcat.util.http.fileupload.FileUploadBase$SizeLimitExceededException: the request was rejected because its size (93796698) exceeds the configured maximum (52428800)

does anyone know a solution?

Best Regards

Mônica

Best answer by posipova

How do you deploy the war file, through web browser or manually?

I would recommend manually copying the thingworx.war inside the <tomcat installation folder>webapps directory while the tomcat service is stopped.

Example: C:\Program Files\Apache Software Foundation\Tomcat 8.0\webapps

4 replies

posipova20-TurquoiseAnswer
20-Turquoise
July 24, 2017

How do you deploy the war file, through web browser or manually?

I would recommend manually copying the thingworx.war inside the <tomcat installation folder>webapps directory while the tomcat service is stopped.

Example: C:\Program Files\Apache Software Foundation\Tomcat 8.0\webapps

20-Turquoise
July 24, 2017

Follow up, you may also change maxPostSize in the http server tomcat connector located in /conf/server.xml as follows:

<Connector connectionTimeout="20000" port="8080" protocol="HTTP/1.1" redirectPort="8443" maxPostSize="104857600"/> 

Set maxPostSize to 104857600 increase the upload file size to 100 Mo. By default it's set to 2 Mo.

For more explanation, read this : https://tomcat.apache.org/tomcat-7.0-doc/config/http.html