Skip to main content
1-Visitor
August 22, 2017
Question

Getting error while configuring communication settings of analytics server in Builder

  • August 22, 2017
  • 7 replies
  • 3236 views

Hello everyone,

While configuring communication settings of analytics server in Builder we are getting below  error .

"Error invoking service.Invalid analytics server version."

we gave "/analytics" in  Endpoint host as suggested in some thread.

Application ID : given by generating new application key in thingworx composer.

Application Key : given like small string.

One doubt we are having.. Thingworx analytics  URL( http://**.**.**.**:8080/analytics/  )

needs to accessible from this machine where we have launched Thingworx composer.?

Currently this URL is opening from the machine where server has installed. How to make it accessible from other machines  which are in same network.

below are the versions of components.

Thingworx :8.0.1

Thingworx Analytics  :8.0.0

Thingworx extension version : 8.0.0

Please help.

Regards,

Raji.

7 replies

5-Regular Member
August 22, 2017

Hello, Raji Vuta.

If I understand correctly, you're having problems accessing the URL of the Analytics server from machines other than the server host? Can you verify that the port 8080 is not in use by some other service, and that the firewall(s) are not blocking traffic on that port.

Thank you,

-- Craig A.

rvuta11-VisitorAuthor
1-Visitor
August 23, 2017

Hi Craig,

Thanks for your response.

We are working with network team to check this firewall blocking issue.

So to get more clear idea on this want to conform one more point

Network team has  to check firewall blocking issue of my main machine that is where this docker has been hosted right.

Regards,

Raji

5-Regular Member
August 23, 2017

Hi Raji,

Yes, correct. From Thingworx you will create access to Analytics Server.

Therefore Analytics Server needs to be accessible.

Best,

Asia

rvuta11-VisitorAuthor
1-Visitor
August 24, 2017

Hi ,

Can anyone  please provide DockerMachinePTC settings configurations, which helps to access  Analytics URL from other machines as well

We tried Bridge mode as network type also by referring below link

How to connect to a docker container from outside the host (same network) [Windows] - Stack Overflow

still problem not resolved.

As per above thread we ran docker run -p 8080:8080 dockertest this commnad

but it has directed to another error by creating one more new container

Regards,

Raji