Skip to main content
1-Visitor
March 17, 2017
Solved

Installed ThingWorx6.5 and get below neo4j db error in Tomcat's log.

  • March 17, 2017
  • 2 replies
  • 1315 views

16-Mar-2017 19:01:47.593 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 45408 ms

rg.neo4j.kernel.impl.transaction.XaDataSourceManager@53da5e37' was successfully initialized, but failed to start. Please see attached cause exception.

at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:513)

at org.neo4j.kernel.lifecycle.LifeSupport.start(LifeSupport.java:115)

at org.neo4j.kernel.InternalAbstractGraphDatabase.run(InternalAbstractGraphDatabase.java:346)

Caused by: org.neo4j.kernel.impl.storemigration.StoreUpgrader$UpgradingStoreVersionNotFoundException: 'neostore.nodestore.db' does not contain a store version, please ensure that the original database was shut down in a clean state.

at org.neo4j.kernel.impl.storemigration.UpgradableDatabase.checkUpgradeable(UpgradableDatabase.java:78)

at org.neo4j.kernel.impl.storemigration.StoreMigrator.needsMigration(StoreMigrator.java:135)

Best answer by ptc-4213616

Never mind. It is resolved.

I had installed previous version and removing ThingworxStorage and ThingworxBackupStorage folder did help.

2 replies

ptc-42136161-VisitorAuthorAnswer
1-Visitor
March 17, 2017

Never mind. It is resolved.

I had installed previous version and removing ThingworxStorage and ThingworxBackupStorage folder did help.

5-Regular Member
March 17, 2017

Hi Pashupati Pandey​,

Could you please mark your answer as correct so that other members know that this issue is resolved.