Skip to main content
1-Visitor
June 7, 2016
Solved

Syntax errors on running twPostgresDBSetup.sh

  • June 7, 2016
  • 7 replies
  • 3304 views

I have setup the Postgres DB in Red Hat Linux Machine. I have also followed all steps as mentioned in the pdf : http://support.ptc.com/WCMS/files/170230/en/Installing_ThingWorx_7.1_1.2.pdf

But while running the TW Postgres DB setup script mentioned in step 14, I am getting syntax errors.

Please let me know how to resolve the issue. The Thingworx, ThingworxPostgresqlStorage and ThingworxPlatform have been created in the same location as mentioned in the document

Best answer by posipova

Running the following two commands from postgres bin directory showed that there were some rpms from 8.4 postgres installation in the OS path. Removing them resolved the issue.

./psql postgres

\set

\q

psql -q -h localhost -U twadmin -p 5432 -v database=thingworx -v tablespace=thingworx -v tablespace_location=/app/navigate/ThingworxPostgresqlStorage -v username=twadmin

\set

7 replies

22-Sapphire I
June 7, 2016

What are the actual errors?

1-Visitor
June 8, 2016

I am getting syntax errors - syntax error at or near ‘:’ when i am running the script for all cases like creating tablespaces, database,etc.

22-Sapphire I
June 8, 2016

To me that sounds like there is an error in one of the files you had to customize.