cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

2D drawing view issue with swept trajpar wire bundle

rburk
10-Marble

2D drawing view issue with swept trajpar wire bundle

I am using Creo6 - version: 6.0.6.0

swept wire bundle using trajpar does not show hidden lines correctly in drawing view.

I've tried changing display settings, part accuracy settings; nothing seems to fix the issue; any ideas ?

 

rburk_0-1708974319779.png

 

 

 

thanks

Rich

1 ACCEPTED SOLUTION

Accepted Solutions
aputman
6-Contributor
(To:MartinHanak)

I was able to get something that works.  For the trajpar feature, remove the circles representing the wires and instead, draw a line connecting the center of each of the circles, creating a triangle.  Sweep this feature and then use the edges of that sweep as the trajectory for the wires.  I don't know why it works but it does for me. 

aputman_0-1709052565807.png

 

View solution in original post

21 REPLIES 21
StephenW
23-Emerald II
(To:rburk)

I am not familiar with wiring but with any solid, if you have interferences, that will cause hidden line issues on drawing/models but typically doesn't affect shaded models/drawings.

rburk
10-Marble
(To:StephenW)

even when I confirm "no interference" still shows incorrectly in drawing views

rburk_0-1708976951163.png

 

StephenW
23-Emerald II
(To:rburk)

Two thoughts:

1 Are the wires solid?, in the model, when you go to wireframe, do they show as surfaces (my color scheme shows them as magenta)

OR

2 how about interference on either end? It looks just like the typical hidden line issue for interference

StephenW_0-1708977626148.png

 

rburk
10-Marble
(To:StephenW)

these are "solid wires"
just showing wire bundle only on drawing - has issues with no-hidden
rburk_1-1708978297117.png

kdirth
20-Turquoise
(To:rburk)

Ensure hidden line removal for quilts is set to yes,

kdirth_0-1708978758549.png

 


There is always more to learn in Creo.
aputman
6-Contributor
(To:rburk)

I have also had issues with this when there are surfaces intersecting one another.  In your case, (assuming the sketch below is correct) each wire has a shared edge (red circles) with both of its neighbors and  Creo can't interpret where the shared edge belongs and likely doesn't even know the proper orientation of the surface.  If you add a gap between the wires, I'm fairly confident this HLR issue will go away. 

aputman_0-1708977447013.png

 

rburk
10-Marble
(To:aputman)

I confirmed sweep sketch has "gaps" 

rburk_0-1708977992431.png

 

tbraxton
21-Topaz II
(To:rburk)

If the wires are tangent, that could be the problem. If they are tangent in the sweep section, then put a small gap in and see if that affects what is seen in the drawing.

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric
rburk
10-Marble
(To:tbraxton)

here's just the wire bundle only (no tangency) & settings  - still not showing correctly in drawing

rburk_0-1708984600114.png

 

MartinHanak
24-Ruby II
(To:rburk)

Hi,

please upload your model + drawing packed in zip file.


Martin Hanák

Hey Martin

I uploaded the wire bundle and drawing issue.

aputman
6-Contributor
(To:rburk)

If you turn on "fasthlr_drawing", the wire bundle displays correctly.  I don't know the full implication of turning on that parameter. 

MartinHanak
24-Ruby II
(To:rburk)


@rburk wrote:

Hey Martin

I uploaded the wire bundle and drawing issue.


Hi,

your model produces correct view until 6 rotations.

I added parameter MH and relation driving length of bundle.

Maybe the problem is related to model accuracy ... unfortunately I was not able to change it to lower value.


Martin Hanák
aputman
6-Contributor
(To:rburk)

Something you could try is sweeping each wire individually rather than as a bundle.  Maybe the HLR process produces better results when the surfaces are separate features. 


@aputman wrote:

Something you could try is sweeping each wire individually rather than as a bundle.  Maybe the HLR process produces better results when the surfaces are separate features. 


Hi,

I tried it ... no success.

Maybe it is necessary to create bundle as assembly with 3 parts representing individual wires.


Martin Hanák

I just tried using 3 bodies within the part in Creo 7 (1 for each wire) and that does not result in the drawing rendering accurately either.

upload_-aW1hZ2UucG5n-1968021327597554084..png

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric
aputman
6-Contributor
(To:MartinHanak)

I was able to get something that works.  For the trajpar feature, remove the circles representing the wires and instead, draw a line connecting the center of each of the circles, creating a triangle.  Sweep this feature and then use the edges of that sweep as the trajectory for the wires.  I don't know why it works but it does for me. 

aputman_0-1709052565807.png

 

To me, it seems to be related using the variable section sweep (and the behind-the scenes algorithms that determine how often the cross-section is computed along the trajectory).  Just a gut feeling, but for example, if this is modeled using plain sweep + warp twist, the drawing shows up correctly:

pausob_0-1709069826487.png

 

rburk
10-Marble
(To:aputman)

since we are still on Creo6,

I was able to make it work using your method - edges of surface for the wire sweeps

now dwg shows "no hidden" correctly

rburk_0-1709136005488.png

thanks for all the help

Rich

kdirth
20-Turquoise
(To:rburk)

Here is what I get opening your drawing:

kdirth_0-1709054451505.png

Not sure what the difference is in my config.  I don't have fasthlr_drawing set.  


There is always more to learn in Creo.
aputman
6-Contributor
(To:kdirth)

Newer version of Creo perhaps.  I'm using Creo 8 and I see what the OP sees when I open their drawing. 

Top Tags