cancel
Showing results for 
Search instead for 
Did you mean: 
Security Alert Log4j Security Vulnerability. Click here to know more.
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Hide Quilt Edges

ThoRig
12-Amethyst

Cannot Hide Quilt Edges

Community,

 

I have imported a complex model that is made up entirely of quilts, and of course, quilts have edges.  After importing the model into Creo 6 and selecting the No Hidden icon, all the lines still show through like a wireframe display.  I cannot display the model online, but no matter what combination of system colors I try, they always show through, even with Black on White.  There is nothing in the layer tree to turn off, it's all quilts.  Has anyone encountered this before, and is there a solution?  Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

In the drawing view options, under View Display, there is Hidden line removal for quilts.  Select the Yes radial button.  This should treat a quilt as a solid and hide anything behind a quilt if Display style is set to No Hidden, and make all edges behind a quilt hidden if the Display style is set to Hidden.

 

Not sure there is anything you can do for the model view.


There is always more to learn in Creo.

View solution in original post

13 REPLIES 13
StephenWilliams
22-Sapphire III
(To:ThoRig)

Is this a drawing view? Or a model? Is there a x-section turned on?

Visibility get funny with x-sections turned on sometimes, not all the time.

If its a drawing and you have a x-section in the view, edit the cross section, select the options tab and select the "include all quilts".

 

 

Thanks for responding.  It's actually both.  But let's start with the model view, because the drawing view is related to the model.  You know the display style types, such as, shaded, shaded with edges, hidden, no hidden wireframe, etc.

 

When I select HIDDEN, that's suppose to hide the lines that are behind the surfaces.  Instead, when I select HIDDEN, it's just like WIREFRAME, and all edges can be seen.  The models is an imported STEP file composed of all quilts.

 

Never seen anything like it before.  I tried system settings Black-on-White, that didn't fix it.  I didn't know if this was the best board to place the topic.

StephenWilliams
22-Sapphire III
(To:ThoRig)

If you shade it, it looks correct? I have seen some problems with "sides" of surfaces being see thru. It's been years tho.

Shading or Shading with Edges, no problem, looks great.

In the drawing view options, under View Display, there is Hidden line removal for quilts.  Select the Yes radial button.  This should treat a quilt as a solid and hide anything behind a quilt if Display style is set to No Hidden, and make all edges behind a quilt hidden if the Display style is set to Hidden.

 

Not sure there is anything you can do for the model view.


There is always more to learn in Creo.

View solution in original post

ThoRig
12-Amethyst
(To:kdirth)

Thanks kdirth.  That fixed it in the drawing, which is ultimately what I was trying to do.  That is an amazing tip.  For the solid model environment, I still cannot get it right.  Even setting the config option display to "hiddeninvis" did not fix it, and I thought that would do it.

 

I will take the solid model "problem" to tech support and see if they can determine the cause.  Thanks again.

ThoRig
12-Amethyst
(To:kdirth)

I found out how to hide those lines in the model view.  I had to go to the config options settings and do the following:

Model Display>Fast hidden lines removal

 

Now, what's strange about this is I didn't have to reorient the model for this to work.  It just turned off all those hidden lines that were bleeding though the quilts and keeps them off.  This is suppose to work when you, for example, spin the model, and all those hidden lines go away until you stop moving the model.

StephenWilliams
22-Sapphire III
(To:ThoRig)

I turned off fast HLR due to issues years ago. I didn't even think about that one.

Edit the definition of the import feature and go into Import Data Doctor (IDD).  See if there are wire-frame edges embedded inside.

ThoRig
12-Amethyst
(To:rzukowski)

Okay...I will try that.  Thanks.

ThoRig
12-Amethyst
(To:rzukowski)

I went into the IDD (something I hardly use), and I could not determine if there were wire frame edges "embedded".  Sure, there are wire frames, but how can you tell if they are "embedded"?  Thanks.

They would show up in the tree in a separate group from the surface component.

 

wire.png

ThoRig
12-Amethyst
(To:rzukowski)

Thanks for the response.  I did not have those.

Announcements