cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

Turn off Intent Manager in Creo 7 to import DWG with a lot of elements (lines, arcs).

JD_9876527
4-Participant

Turn off Intent Manager in Creo 7 to import DWG with a lot of elements (lines, arcs).

I am using Creo Parametric - Release 7.0 (connected) 7.0 7.0.0.0

Importing a DWG file into sketcher which is very large (a lot of line, arc segments) and the message tells me it will take a long time with Intent Manager turned on. How do I turn this off temporarily so it wont try to resolve the sketch to try to dimension every single element?

How do I turn off Intent Manager in Creo 7?

Here are the errors that I faced
You are attempting to import too many entities into Sketcher. With Intent Manager turned on, processing this amount of entities may take very long time. If you wish, you may hit the Select button to open a subwindow and select entities you wish to be imported
1 ACCEPTED SOLUTION

Accepted Solutions
JD_9876527
4-Participant
(To:JD_9876527)

The only way I could fix this is to go into AutoCAD and trace over the original drawing with splines, lines and arcs to reduce the number of elements.  I had to "explode" it first.  Delete all the original geometry and then reimport it as fewer elements.

 

Initially, I tried the "Select" option but I couldn't line up the parts of the sketch perfectly; so, that idea was a "non-starter".

View solution in original post

4 REPLIES 4
StephenW
23-Emerald II
(To:JD_9876527)

I don't know how to turn off intent manager.

My work-around is to NOT import directly in to sketcher.

I import in to the part directly. Then I can see the sketch, no worries about resolve mode or entity count.

I will the use the import edges as reference or whatever other purpose I need.

Strongly agree with this. I've gotten system layouts and facility drawings that we wanted to use to sketch stuff in Creo and it never works. The line counts in a drawing from, for example AutoCAD, are extreme. The import always chokes to death on all the entities.

JD_9876527
4-Participant
(To:JD_9876527)

The only way I could fix this is to go into AutoCAD and trace over the original drawing with splines, lines and arcs to reduce the number of elements.  I had to "explode" it first.  Delete all the original geometry and then reimport it as fewer elements.

 

Initially, I tried the "Select" option but I couldn't line up the parts of the sketch perfectly; so, that idea was a "non-starter".

FYI, if you need a cosmetic sketch, not a regular sketch, then you can activate "under-constrained mode" under sketch-setup fly-down.  That will basically turn off the intent manager (for the cosmetic sketch)

Top Tags