cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Automatic Sketcher Reference Plane

dgschaefer
21-Topaz II

Automatic Sketcher Reference Plane

Creo2 M120

 

When creating a sketch, Creo will sometimes automatically select a reference plane.  Many times that isn't the plane I want to use, so I always go back and check it.

 

Is there a config option to force Creo to prompt me for a reference plane?  I searched the config editor and came up empty.


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
1 ACCEPTED SOLUTION

Accepted Solutions
JLG
1-Newbie
1-Newbie
(To:dgschaefer)

For what it's worth, the config option enable_face_preselection can be set to no to disable the preselection thus forcing you to choose both planes. Unfortunately, I don't know of an option that will only force selection of the orientation plane.

View solution in original post

11 REPLIES 11

Doug,

Creo always prompt you for the reference plane when creating a Sketch.

1.jpg

Actually, there are a couple of ways to enter sketcher without a prompt for a reference plane.

 

  1. If you select a plane and then select a command like extrude, Creo goes straight into sketcher with no ref plan prompt.
  2. If you select a command like extrude and then select a plane, Creo goes straight into sketcher with no ref plan prompt.

 

Those are both handy workflows, I'd simply like to be presented with the sketch setup dialog every time so I can very the reference plane that Creo has assumed for me.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
MarkHeinze
5-Regular Member
(To:dgschaefer)

This issue of automatically selected sketcher reference bothers me too (double work to have to go back and re-select). With everything being parametric, I've been caught too often with inappropriate sketcher references.To be prompted for the sketcher reference for me is a must (how is Creo to know MY intent?).

So what work flow procedure (and settings) is required if I want to ALWAYS be prompted for the sketcher reference?

You will always be prompted for a second sketcher reference if you start the feature creation (such as extrude or revolve) with no datum planes selected. Choose 'Placement', then 'Define', the sketch plane window appears, pick your sketch plane followed by your sketch orientation reference. This is the only way I know that guarantees the references you want.

John

To be clear, I'm talking here about the sketcher reference plane (that orients sketcher), not the internal sketcher references.  Both are issues, however, in terms of parent child relationships.

 

You can force Creo to prompt you for the sketcher reference plane by entering the sketcher environment only by the dashboard "define" button with no plane pre-selected.

 

To force Creo to prompt you for internal sketcher references, set the config.pro option "sketcher_auto_create_refs" to "0" (that's a zero).  Creo will then open the references dialog as soon as you enter the sketcher and will not select any references for you.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

Hi Doug, this catches me out time & time again. I think there is a quick route to sketcher where only one reference is needed & the second is automatically selected as you stated, usually not the one you want. In my experience, if you have a datum plane already selected going into feature creation, then that datum becomes your sketch plane & a second reference is automatically created. If however no datum plane is selected, & you work through the sketch plane setup by selecting 'placement', then 'define' sketch, then you will be prompted for a second reference. I could be wrong, but i think this short cut to sketcher environment must have started in Creo 1, it does not appear to have this behaviour in Wildfire 5.

Regards

John

config.pro option :"sketcher_auto_create_refs" set the value to "zero"

this is in creo 2.0

I have that set but it has no impact on the sketcher reference plane.  It only prevents Creo from adding default references inside sketcher.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

my mistake...i miss understood you question

JLG
1-Newbie
1-Newbie
(To:dgschaefer)

For what it's worth, the config option enable_face_preselection can be set to no to disable the preselection thus forcing you to choose both planes. Unfortunately, I don't know of an option that will only force selection of the orientation plane.

dgschaefer
21-Topaz II
(To:JLG)

This is closer, but not much. By setting this option, Creo will not let you pick the plane before entering the feature.  So if I choose a plane and then hit the extrude tool, Creo presents the sketch setup dialog - with nothing selected.  That's better.

 

However, if I hit the extrude tool and then select a plane, Creo goes right into sketcher, having chosen the reference plane for me.

 

I've created a product idea to add an option to control this.  Please vote for it here.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
Announcements
Attention: Creo 7.0 Customers
Please consider upgrading
End of Life announcement here.

NEW Creo+ Topics: PTC Control Center and Creo+ Portal