Skip to main content
1-Visitor
May 24, 2017
Question

Tomcat Error Installing Thingworx 7.4

  • May 24, 2017
  • 21 replies
  • 8133 views

Hi,

I am getting this error while deploying TWX jar file on tomcat.

24-May-2017 18:24:11.706 INFO [localhost-startStop-1] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.

But after changing "catalina.properties" and adding "jarsToSkip" tag with few selected jars which I found on internet,

Tag added to "catalina.properties" :

tomcat.util.scan.StandardJarScanFilter.jarsToSkip=\

jboss-logging.jar,mod_cluster-container-tomcat8.jar,mod_cluster-core.jar,mod_cluster-container-catalina-standalone.jar,mod_cluster-container-spi.jar,mod_cluster-container-catalina.jar


I am getting this error:

"24-May-2017 18:24:11.705 WARNING [localhost-startStop-1] org.apache.tomcat.util.scan.StandardJarScanner.scan Failed to scan [file:/C:/Program%20Files/Apache%20Software%20Foundation/Tomcat%208.0/bin/commons-daemon.jar] from classloader hierarchy

java.io.FileNotFoundException: C:\Program Files\Apache Software Foundation\Tomcat 8.0\bin\commons-daemon.jar (The system cannot find the file specified)

  at java.util.zip.ZipFile.open(Native Method)

  at java.util.zip.ZipFile.<init>(Unknown Source)

  at java.util.zip.ZipFile.<init>(Unknown Source)

  at java.util.jar.JarFile.<init>(Unknown Source)

  at java.util.jar.JarFile.<init>(Unknown Source)

  at org.apache.tomcat.util.scan.JarFileUrlJar.<init>(JarFileUrlJar.java:60)

  at org.apache.tomcat.util.scan.JarFactory.newInstance(JarFactory.java:48)

  at org.apache.tomcat.util.scan.StandardJarScanner.process(StandardJarScanner.java:334)

  at org.apache.tomcat.util.scan.StandardJarScanner.scan(StandardJarScanner.java:284)

  at org.apache.jasper.servlet.TldScanner.scanJars(TldScanner.java:262)

  at org.apache.jasper.servlet.TldScanner.scan(TldScanner.java:106)

  at org.apache.jasper.servlet.JasperInitializer.onStartup(JasperInitializer.java:101)

  at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5303)

  at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:145)

  at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:725)

  at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:701)

  at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:717)

  at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1092)

  at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1834)

  at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

  at java.util.concurrent.FutureTask.run(Unknown Source)

  at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

  at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

  at java.lang.Thread.run(Unknown Source)

24-May-2017 18:24:11.706 INFO [localhost-startStop-1] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.

24-May-2017 18:24:11.709 INFO [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployDirectory Deployment of web application directory C:\Program Files\Apache Software Foundation\Tomcat 8.0\webapps\ROOT has finished in 841 ms

24-May-2017 18:24:11.713 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-8080"]

24-May-2017 18:24:11.719 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["ajp-nio-8009"]

24-May-2017 18:24:11.721 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 4621 ms"

Please help me to get this solve.....

Thanks.

21 replies

5-Regular Member
May 24, 2017

Prashant, what's the Tomcat and ThingWorx version?

1-Visitor
May 25, 2017

Hi Sushant,

Thanks for replying.

Tomcat : apache-tomcat-8.0.38

Thingworx : 7.4 version

1-Visitor
May 25, 2017

I installed TWX war file but this is not getting started:

I am getting this Error in Application Logs of TWX :

2017-05-25 14:21:21.340+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-05-25 14:21:21.341+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ThingWorx Version Information

2017-05-25 14:21:21.341+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-05-25 14:21:21.341+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] majorVersion = 7

2017-05-25 14:21:21.341+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] minorVersion = 4

2017-05-25 14:21:21.341+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] revision = 1

2017-05-25 14:21:21.341+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] build = b62

2017-05-25 14:21:21.341+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] schemaVersion = 940

2017-05-25 14:21:21.342+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-05-25 14:21:21.342+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-05-25 14:21:21.342+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ThingWorx System Environment Settings

2017-05-25 14:21:21.342+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-05-25 14:21:21.342+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] OS: Windows 7

2017-05-25 14:21:21.342+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] OS arch: amd64

2017-05-25 14:21:21.342+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] OS version: 6.1

2017-05-25 14:21:21.343+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Total Processors: 8

2017-05-25 14:21:21.343+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Default encoding: UTF-8

2017-05-25 14:21:21.343+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] JAVA vendor: Oracle Corporation

2017-05-25 14:21:21.343+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] JAVA version: 1.8.0_40

2017-05-25 14:21:21.343+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] JAVA install location: C:\Program Files\Java\jre1.8.0_40

2017-05-25 14:21:21.343+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] JVM Max Memory: 3003 (MB)

2017-05-25 14:21:21.343+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-05-25 14:21:21.343+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] WebApp starting...

2017-05-25 14:21:24.617+0530 [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] HA mode not enabled. Initializing and starting in standalone mode.

2017-05-25 14:21:24.617+0530 [L: INFO] [O: c.t.s.ThingWorxPersistenceHandler] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Default Persistence Provider Name = ThingworxPersistenceProvider

2017-05-25 14:21:24.617+0530 [L: INFO] [O: c.t.s.ThingWorxPersistenceHandler] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Default Persistence Provider Package Name = MssqlPersistenceProviderPackage

2017-05-25 14:21:24.632+0530 [L: INFO] [O: c.t.p.m.MssqlDatasource] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Reading configuration from configTableCol

2017-05-25 14:21:27.063+0530 [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Managers...INITIALIZED

2017-05-25 14:21:27.067+0530 [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Database initialization started...

2017-05-25 14:21:57.219+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9ohfbpwulv987h|5345b039]-HelperThread-#7] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@523131f9 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:

2017-05-25 14:21:57.219+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9ohfbpwulv987h|5345b039]-HelperThread-#4] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@47b39203 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:

2017-05-25 14:21:57.219+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9ohfbpwulv987h|5345b039]-HelperThread-#5] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@3f928885 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:

2017-05-25 14:21:57.219+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9ohfbpwulv987h|5345b039]-HelperThread-#1] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@6ccefcd0 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:

2017-05-25 14:21:57.219+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9ohfbpwulv987h|5345b039]-HelperThread-#0] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@62bf2fe3 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:

2017-05-25 14:21:57.221+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9ohfbpwulv987h|5345b039]-HelperThread-#7] Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@58127c01 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

2017-05-25 14:21:57.223+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9ohfbpwulv987h|5345b039]-HelperThread-#0] Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@58127c01 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

2017-05-25 14:21:57.223+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9ohfbpwulv987h|5345b039]-HelperThread-#1] Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@58127c01 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

2017-05-25 14:21:57.223+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9ohfbpwulv987h|5345b039]-HelperThread-#5] Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@58127c01 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

2017-05-25 14:21:57.223+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9ohfbpwulv987h|5345b039]-HelperThread-#4] Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@58127c01 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

2017-05-25 14:21:57.229+0530 [L: ERROR] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] [message: Connections could not be acquired from the underlying database!]

2017-05-25 14:21:57.267+0530 [L: INFO] [O: c.t.p.p.PersistenceProvider] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Connection ThingworxPersistenceProvider, type MssqlPersistenceProviderPackage stopped

2017-05-25 14:21:57.268+0530 [L: WARN] [O: c.t.p.p.PersistenceProvider] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Could not find persistenceProviderPackage MssqlPersistenceProviderPackage and thus could not stop data processing

2017-05-25 14:21:57.295+0530 [L: ERROR] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] [message: Unable to initialize and start system: Connections could not be acquired from the underlying database!]

2017-05-25 14:21:57.296+0530 [L: ERROR] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] *** Web Application STATE is being set to ERROR! ***

2017-05-25 14:23:03.247+0530 [L: ERROR] [O: c.t.s.a.AuthenticationFilter] [I: ] [U: ] [S: ] [T: http-nio-8080-exec-5] Could not handle request

2017-05-25 14:23:05.408+0530 [L: ERROR] [O: c.t.s.a.AuthenticationFilter] [I: ] [U: ] [S: ] [T: http-nio-8080-exec-6] Could not handle request

Please help me from this onwards :

Also my platform.json file is attached below :

5-Regular Member
May 25, 2017

Prashant Kumar Agrawal​ : Application is not able to connect to the database so could you please check/verify the JDBC URL along with Database username and password ?

2017-05-25 14:21:57.229+0530 [L: ERROR] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] [message: Connections could not be acquired from the underlying database!]

-Durgesh

20-Turquoise
June 6, 2017

could you please show your exact platform-settings.json file?

And if this is a postgresql instance, please show the view of your pg admin when all spaces under "thingworx" database are expanded.

1-Visitor
June 6, 2017

No this is MS SQL, Polina.

I have attached the file in previous post, you can find that in 4th post.

Thanks.

20-Turquoise
June 6, 2017

Try with this file.

1-Visitor
June 6, 2017

Nope Again the same error.

Here is the log:

"

2017-06-06 20:08:46.964+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-06-06 20:08:47.001+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ThingWorx Version Information

2017-06-06 20:08:47.001+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-06-06 20:08:47.002+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] majorVersion = 7

2017-06-06 20:08:47.002+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] minorVersion = 4

2017-06-06 20:08:47.002+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] revision = 1

2017-06-06 20:08:47.002+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] build = b62

2017-06-06 20:08:47.002+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] schemaVersion = 940

2017-06-06 20:08:47.003+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-06-06 20:08:47.003+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-06-06 20:08:47.003+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ThingWorx System Environment Settings

2017-06-06 20:08:47.003+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-06-06 20:08:47.003+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] OS: Windows 7

2017-06-06 20:08:47.004+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] OS arch: amd64

2017-06-06 20:08:47.004+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] OS version: 6.1

2017-06-06 20:08:47.004+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Total Processors: 8

2017-06-06 20:08:47.004+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Default encoding: UTF-8

2017-06-06 20:08:47.004+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] JAVA vendor: Oracle Corporation

2017-06-06 20:08:47.004+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] JAVA version: 1.8.0_40

2017-06-06 20:08:47.004+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] JAVA install location: C:\Program Files\Java\jre1.8.0_40

2017-06-06 20:08:47.005+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] JVM Max Memory: 3070 (MB)

2017-06-06 20:08:47.005+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ========================================

2017-06-06 20:08:47.005+0530 [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] WebApp starting...

2017-06-06 20:08:49.814+0530 [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] HA mode not enabled. Initializing and starting in standalone mode.

2017-06-06 20:08:49.814+0530 [L: INFO] [O: c.t.s.ThingWorxPersistenceHandler] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Default Persistence Provider Name = ThingworxPersistenceProvider

2017-06-06 20:08:49.814+0530 [L: INFO] [O: c.t.s.ThingWorxPersistenceHandler] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Default Persistence Provider Package Name = MssqlPersistenceProviderPackage

2017-06-06 20:08:49.846+0530 [L: INFO] [O: c.t.p.m.MssqlDatasource] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Reading configuration from configTableCol

2017-06-06 20:08:51.994+0530 [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Managers...INITIALIZED

2017-06-06 20:08:51.998+0530 [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Database initialization started...

2017-06-06 20:09:22.151+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9oyx0q8emtppx2|5726e03b]-HelperThread-#5] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@497d06b7 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:

2017-06-06 20:09:22.153+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9oyx0q8emtppx2|5726e03b]-HelperThread-#3] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@6391fa46 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:

2017-06-06 20:09:22.153+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9oyx0q8emtppx2|5726e03b]-HelperThread-#0] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@d40ccf4 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:

2017-06-06 20:09:22.152+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9oyx0q8emtppx2|5726e03b]-HelperThread-#4] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@4e3d584a -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:

2017-06-06 20:09:22.151+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9oyx0q8emtppx2|5726e03b]-HelperThread-#1] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@6da6f8da -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:

2017-06-06 20:09:22.153+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9oyx0q8emtppx2|5726e03b]-HelperThread-#5] Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@6929e511 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

2017-06-06 20:09:22.155+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9oyx0q8emtppx2|5726e03b]-HelperThread-#1] Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@6929e511 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

2017-06-06 20:09:22.155+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9oyx0q8emtppx2|5726e03b]-HelperThread-#4] Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@6929e511 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

2017-06-06 20:09:22.155+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9oyx0q8emtppx2|5726e03b]-HelperThread-#0] Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@6929e511 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

2017-06-06 20:09:22.155+0530 [L: WARN] [O: c.m.v.r.BasicResourcePool] [I: ] [U: SuperUser] [S: ] [T: C3P0PooledConnectionPoolManager[identityToken->313nwc9oyx0q8emtppx2|5726e03b]-HelperThread-#3] Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@6929e511 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

2017-06-06 20:09:22.161+0530 [L: ERROR] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] [message: Connections could not be acquired from the underlying database!]

2017-06-06 20:09:22.191+0530 [L: INFO] [O: c.t.p.p.PersistenceProvider] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Connection ThingworxPersistenceProvider, type MssqlPersistenceProviderPackage stopped

2017-06-06 20:09:22.191+0530 [L: WARN] [O: c.t.p.p.PersistenceProvider] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Could not find persistenceProviderPackage MssqlPersistenceProviderPackage and thus could not stop data processing

2017-06-06 20:09:22.219+0530 [L: ERROR] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] [message: Unable to initialize and start system: Connections could not be acquired from the underlying database!]

2017-06-06 20:09:22.219+0530 [L: ERROR] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] *** Web Application STATE is being set to ERROR! ***

2017-06-06 20:09:54.835+0530 [L: ERROR] [O: c.t.s.a.AuthenticationFilter] [I: ] [U: ] [S: ] [T: http-nio-8080-exec-3] Could not handle request"

20-Turquoise
June 6, 2017

Do you have full access permissions on the platform storage folder? As in, this should be checked:

I would also try changing the password to see if "@" character might be a cause.