Skip to main content
1-Visitor
October 21, 2011
Solved

File Upload problem after windows security patch update..

  • October 21, 2011
  • 14 replies
  • 5717 views

Hello everyone

We did a Windows patch update on test server and after the patch update, everything is working fine except we are not able to upload anything. The error I am getting reads like this:

An error occured while uploading the file. Please contact your administrator. Error: [object Error]

Java update is not a problem. Even then tried changing the preference to browser upload but still the same case.

Other thing is, After the update the backGround method server log started stacking up like anything with a speed f say around 500 mb an hour. no users are active on this server.

Best answer by MatthewKnight

Honestly, I wouldn't expect upload to fail due to indexing problems. I believe you can set the following propreties to help debug indexing. wt.index.verboseExecution=true, wt.index.verbosePerformance=true, wt.index.verboseDetailedPerformance=true,wt.index.log.enabled=true,

wt.index.log.file=<your choice>,

I'm not sure if those properties are still in use.

Let's eliminate indexing as a possibility.

If you can get the database onto a clone development box, I'd try setting wt.index.enabled=false. Then delete the waiting indexing entries. You may have to use the command line to clear the indexing queue. (wt.queue.QueueManager, I think).

Before any of that, look at the vaulting. Site/Utilities/External Storage Administrator. Validate all of your mounts. More specifically, does Windchill have access to the default folder. What about wc's default temp folder? (wt.temp property). If that looks good, you can try deleting your vaulting rules to eliminate vaulting as a source of the error.

Again, also look at your Windows event logs. Restart Windchill and associated applications/processes/services. Sort the event logs to view the latest and look for red?

14 replies

1-Visitor
October 21, 2011

There are lots of possibilities.

Are you vaulting? Are you indexing? Is Windchill running as a service? What about the associated applications? Check your event log. Are all the services starting correctly? Did a password change?

I'd start with the associated Windchill logs. Do you have anything less generic than "An error occured while uploading the file. Please contact your administrator. Error: [object Error]?"

PardeepS1-VisitorAuthor
1-Visitor
October 21, 2011

yes, Vaulting is there. But issue worth talking about is indexing. There are some waiting entries in Index queue because of which Background method server log is piling up at the rate of noughts. Around 1 GB per hour or so. Cant see any exceptions there, but repeated trails only. Can indexing or IndexQueue have an effect on uploading a file?

Other thing I did was MakeJar. But trie Bootstrap without any success

1-Visitor
October 21, 2011

Honestly, I wouldn't expect upload to fail due to indexing problems. I believe you can set the following propreties to help debug indexing. wt.index.verboseExecution=true, wt.index.verbosePerformance=true, wt.index.verboseDetailedPerformance=true,wt.index.log.enabled=true,

wt.index.log.file=<your choice>,

I'm not sure if those properties are still in use.

Let's eliminate indexing as a possibility.

If you can get the database onto a clone development box, I'd try setting wt.index.enabled=false. Then delete the waiting indexing entries. You may have to use the command line to clear the indexing queue. (wt.queue.QueueManager, I think).

Before any of that, look at the vaulting. Site/Utilities/External Storage Administrator. Validate all of your mounts. More specifically, does Windchill have access to the default folder. What about wc's default temp folder? (wt.temp property). If that looks good, you can try deleting your vaulting rules to eliminate vaulting as a source of the error.

Again, also look at your Windows event logs. Restart Windchill and associated applications/processes/services. Sort the event logs to view the latest and look for red?

1-Visitor
October 21, 2011

Pardeep,

Please check your client version of Java plugin, the later versions 1.6.0_24+ (not exaclty sure about the rev) have issues with uploading to WC 9.1. I believe there is a patch available for WC that will allow never java clients.

Suggest downgrading your client to 1.6.0_20 and try your upload again ( that should fix it)

/Cars10

PardeepS1-VisitorAuthor
1-Visitor
October 24, 2011

Thank you for the reply Carsten

Well the thing is java was not a problem before the windows patch update. What I found is that the problem is with the validity of the mounts...

1-Visitor
October 25, 2011

Use jre 6.17 them work fine, before uninstall all other jre & restart pc.

PardeepS1-VisitorAuthor
1-Visitor
October 25, 2011

Feofilov

Thanks for your reply.

The problem is not with JRE. The problem is with the vaulting configuration. Al of a sudden after the update, all mounts have become invalid. Its a dev server and it was rehosted just 2 weeks back. So I guess the person who did the rehosting did not cover all the bases and messed it up. I am trying to validate the mounts but its not happening. I will have to discuss with the one who did rehosting.

PardeepS1-VisitorAuthor
1-Visitor
October 31, 2011

Well, the re-hosting was done and Vault mounts were not validated properly. It all fine now. Thanks friends.