Skip to main content
1-Visitor
September 29, 2011
Question

Installation failure with Javax.naming.Communication exception

  • September 29, 2011
  • 6 replies
  • 4890 views

Hi,

Windchill 10.0M010 installation fails during the WindchillDS installation with below exception

DEBUG 2011-09-29 12:11:06 - javax.naming.CommunicationException: Could not connect to the LDAP Server, ldap port: 389 ldap manager: cn=Manager

DEBUG 2011-09-29 12:11:06 - at com.ptc.ldapserver.install.actions.CheckServerStatus.process(CheckServerStatus.java:83)

DEBUG 2011-09-29 12:11:06 - at com.ptc.windchill.install.framework.InstallAction.run(InstallAction.java:483)

DEBUG 2011-09-29 12:11:06 - at com.ptc.windchill.install.framework.InstallAction.install(InstallAction.java:327)

DEBUG 2011-09-29 12:11:06 - at com.zerog.ia.installer.actions.CustomAction.installSelf(DashoA10*..)

DEBUG 2011-09-29 12:11:06 - at com.zerog.ia.installer.InstallablePiece.install(DashoA10*..)

DEBUG 2011-09-29 12:11:06 - at com.zerog.ia.installer.InstallablePiece.install(DashoA10*..)

DEBUG 2011-09-29 12:11:06 - at com.zerog.ia.installer.GhostDirectory.install(DashoA10*..)

and so on...

All locations including that for Java SDK are pointing to the local drives (no UNC locations) and the error is repeatedly appearing on the virtual machine that I am using. This is a remote installation configuration with oracle on a different system, but active directory host is the same as the virtual machine.

Any suggestions would be helpful. Error snapshot is attached.

AJ

6 replies

1-Visitor
September 30, 2011

Hi AJ,

It looks like WindchillDS failed to start after installer finished it installation.

I had such issue with WC 9.1 on linux vritual machine.

Go to your WDS installation directory and from bin start the DS. I don't know which OS you are using but it should be start-ds .sh or .bat script.

If it will start try to resum the installation.

AJ_2224731-VisitorAuthor
1-Visitor
September 30, 2011

Hi Daniel,

Thanks for the reply. After I get the install abort error, attempting to start WindchillDS tells me that it is already running. Rerunning PSI (recover) but does not recognize the WindchillDS as installed, says WindchillDS folder should be empty for PSI to proceed. Uninstalling WindchillDS and rerunning PSI againd ends up with the same install abort error.

I am using a Windows 2008R2 64 bit OS.

AJ

AJ_2224731-VisitorAuthor
1-Visitor
September 30, 2011

There was a wrong entry in the hosts file for the localhost, and after commenting that out, i was able to successfully complete this install.

1-Visitor
May 20, 2012

Hi AJ,

I am also facing similar kind of problem. Could you please share the correction which you have done in hosts files.

Srikanth

AJ_2224731-VisitorAuthor
1-Visitor
May 21, 2012

Hi Srikanth,

I don't exactly remember, but it was a wrong name or IP address for the Application server. Once I ensured that the name/IP is correct, the error no longer appeared.

-AJ