Skip to main content
1-Visitor
September 15, 2014
Solved

Windchill rehosting

  • September 15, 2014
  • 5 replies
  • 2627 views

Hi!

I have renamed my Windchill instance, but I have trouble like here: https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS45021&posno=1&q=${rhost.wt.federation.ie.namingService}&nav=ptcproductgroups||windchill||Product%20Group||windchill&source=Search

1. I can't find the directory like: <Windchill_DRIVE>\tmp\ptcServlet

2. Where Windchill can keep cashed jndi information?

Best answer by ChrisSpartz

If you can't find the ptcServlet directory, don't worry about it. Just make sure to clear the info engine cache (<WT_HOME>\tasks\codebase\com\infoengine\compiledTasks).

If you've updated the web.xml file like in that article, cleared the info engine cache, and restarted, and you still see errors mentioning the ${rhost.*} values, then check your wt.properties file. These values can also occur in there. The below article gives the properties you should look at and what values they should be set to:
https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS30481

5 replies

13-Aquamarine
September 18, 2014

If you can't find the ptcServlet directory, don't worry about it. Just make sure to clear the info engine cache (<WT_HOME>\tasks\codebase\com\infoengine\compiledTasks).

If you've updated the web.xml file like in that article, cleared the info engine cache, and restarted, and you still see errors mentioning the ${rhost.*} values, then check your wt.properties file. These values can also occur in there. The below article gives the properties you should look at and what values they should be set to:
https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS30481

1-Visitor
September 22, 2014

Thanks, Chris!