Skip to main content
1-Visitor
May 16, 2017
Solved

While updating Thingworx from 7.1 to 7.3, got error when executing sh thingworxPostgresSchemaUpdate7.1-to-7.2.sh

  • May 16, 2017
  • 2 replies
  • 2388 views

Error while executing sh thingworxPostgresSchemaUpdate7.1-to-7.2.sh:-

psql:./thingworx-update-model-data-7.1-to-7.2.sql:7: ERROR:  duplicate key value violates unique constraint "user_model_properties_pkey"

Kindly update if someone get the same error.

Best answer by posipova

Have you downloaded the latest 7.2 version?  This seems like an issue in which "#" were placed in user names.

Try running the following query in pgadmin/psql - DELETE FROM user_model_properties WHERE entity_name LIKE '%#User

2 replies

posipova20-TurquoiseAnswer
20-Turquoise
May 16, 2017

Have you downloaded the latest 7.2 version?  This seems like an issue in which "#" were placed in user names.

Try running the following query in pgadmin/psql - DELETE FROM user_model_properties WHERE entity_name LIKE '%#User

hkaur-41-VisitorAuthor
1-Visitor
June 5, 2017

Hi polina this has been worked... Thanks a lot