Take the Windchill Satisfaction Survey!
Recently active
We are trying to achieve communication from Kepware to Kepware, when i am trying to generate tags the following error is being encountered.Failed to Connect to UA server 'opc.tcp://10.XX.XX.12:49320' for browsing.
I am trying to write a value and a timestamp from an OPC UA client to KEPServerEX OPC UA Server. The OPC client is unable to write the value and timestamp it seems. Is there anyway to allow for the OPC UA Client to write a timestamp to KepServers OPC UA Server
Hello All,in KepServerEX6 I created a channel to get data from an SQL database.I created a Device for a table and it was not able to populate the tags automatically, like the previous two tables I created on that channel seemed to do. If I did something differently, I can't figure out what that is. The setup is the same as the other two.The error it returned when finishing the new device was: "Unable to generate a tag database for <MY DEVICE>:Automatic tag generation for device <MY DEVICE>' refused due to active client connections"I read another topic which had the same error. The suggestion was to 'Close all OPC client connections to the device and retry Automatic Tag Generation' Another topic said to create a new channel but I'm hoping to keep this table on the same database channel, to preserve the same organization between SQL and Kepware. My question is, how do I 'Close all OPC client connections to the device and retry Automatic Tag Gen
Manufacturing license - Add a new device. Hello, I have a Kepware KepServerEX 6 running for a customer and want to add a Siemens PLC to the OPC server.The license I have is a manufacturing Suite with Tier: DriverLimit 1. What does this mean? Cannot find any explanation about this anywhere.And on this OPC server I have a memory based connection running.Is it possible to add a new Siemens PLC S7-300 device to the Kepserver without needing to change the license? The manufacturing Suite does have the Siemens drivers included.
After communication fails and got resumes between Kepware and COMPACTLOGIC PLC, but the link is not writing value to the PLC. After disabling and enabling the link tag then it starts writing the value to plc . But it has to happen automatically without reenabling the link tag.Please suggest a solution regarding this asap
Good day. Can someone please assist me, I am trying to connect the codesys control win v3 x64 virtual PLC to the Kepserver OPC but it refuses. I can't browse the PLC tags as well. Even if use an actual PLC (wago PFC100), still it shows that there is no communication between my server and my PLC. Manually adding the tags, still there will be no communication between the server and The PLC. After adding a channel on Kepserver, when I try to use the discover device option to add the device, it's still refusing. When I manually add the device using the device address, still there is no communication. I have attached screenshots of the error messages which I am getting.
Hi, I have installed KepwareEx6 (v6.14) with GE Ethernet Suite option on a VM and set it up to read from an Emerson (old GE) PLC that has a CPE330 CPU. On the same VM that Kepware is installed, I have also installed a GE Historian Collector that is set up to collect data from Kepware using OPC DA and send the data to our native GE Historian. This way I can log data from the PLC to our GE Historian every 100 ms. My PLC scan time, however, is between 4 to 5 ms. So, for every sample logged by the Historian I am missing potentially 24 samples from the PLC. If I know when Kepware reads from the PLC then in the PLC I can use that signal as a trigger to find the Minimum, Maximum and Average of the 25 PLC samples of data that correspond to the one sample that Kepware reads every 100 ms and log these statistical values as a separate tag to get a feel about the missing samples. So, this way for each signal of interest from PLC I will have 4 tags: The instantaneous value of the tag
Hi, it been a while since I used KepServer and I have a new project scope that's got me scratching my head a bit. We have a requirement to automate production test data acquisition where there is nothing currently in place. There are no OPC enabled drivers at all for the instrumentation types that we use. We're building the back office tooling (SQL DB, internal web services etc) to support quite complex product assembly and testing, where manual data entry is needed. The final step is to provision device level integration to bypass the need for manual data entry. Typically, the multiple (5) USB devices are tethered to a local PC, each with proprietary data communication. I'm looking for a confident way forward. The concept I'm working with is to centralise the data on an instance of KEPServerEX, with local OPC servers running on the PC hosts that harvest the production data from the locally connected devices. KepServerEx is the product I know from the past, I am only jus
Anyone using Kepware with MT-Connect? I am reading data from various equipment in multiple plants. I am configuring tags for alarm states. MT-Connect outputs multiple condition statements with the same 'ID'. Anyone know how to see the second or 3rd condition statement in the Kepware tag? Or Create an additional tag to see the secondary or tertiary statement? Kepware Tag Reading value- MT-Connect Output-
My certificate is expired and I need to reissue.Date Time Level Source Event17/10/2023 09.52.42 Error UA Server The UA server certificate is expired. Please use the OPC UA Configuration Manager to reissue the certificate.When I try to login to administration window (after loading OPC UA Configuration program) I can't login, I have no feedback after entering credentials.Someone with the same problem?Just updated from 6.9 to 6.11, nothing changed.
I have installed this software on windows 10 pro OS. Whenever i try to select the driver in connectivity option like OPC DA client/ UA client the application window gets exited without any error.
We are faced with the situation that the queries sent to an OPC UA server from Kepware Server lead to insufficient resources on the control computer. Now we are looking for optimization possibilities to relieve the load on the CPU of the PLC. In doing so, we came across the complex types. Is it possible to reduce the load caused by querying the data points by using them? From the documentation:
Please suggest for data polling from ABB 800XA 6.0.0 to computer which is in restricted company network policy in domain. can I do it with kepserverex 5.5 version, what driver/service i have to get additionally. Controller is ABB 800M. Computer configuration is redundant server/client.
Hi!Do you have any hardware requirement recommendations for kepware depending on connected PLC, tag number, and data change rate?For example, if we going to connect 500 PLC with 200 tags per PLC, and we need high read rates (1s, max 2 sec delay) for 10 tags per PLC, what are the HW recommended requirements for our KW server?(KEPServerEX v6.13 Manufacturing Suite) Thanks!
I have a tag on a Molding press for Cooling Time that counts up and then zeroes out. I am writing the data to a database using a trigger called New Data Flag. When the new data flag kicks from 0 to 1 I write the data to the database. Unfortunately the cooling time tag is at zero when the new data flag changes over. So I think I can fix this by creating an advanced tag that will monitor the Cooling Time tag. I only want the advanced tag to update if the Cooling time tag is not zero. By doing this I will always end up with the last non zero value from the Cooling Time tag when the New Data Flag changes from 0 to 1. My assumption is that a derived tag may work but I am not sure how to setup the expression. Any help would be appreciated.
I am trying to read a tag using IoT Gateway.I am using POSTMAN as testing toolGET http://143.28.91.145:39320/iotgateway/read?ids=LPDASTTT.UPack_To_FDM_Alex.PO_Download.Init.ProductID.DATA/8 with no authentication gives me proper result,butGET http://143.28.91.145:39320/iotgateway/read?ids=LPDASTTT.UPack_To_FDM_Alex.PO_Download.Init.ProductID.DATA/8 with basic authentication and username Administrator and password (my Administrator password for KepserverEX) returns 500 internal server error. The version of kepserver is 6.11
Hi everybody, I have installed the tuneller KEPServerEX 6 version 6.5.829.0 and a weeks ago we are experimenting interruptions in the transmision of the data. I track the problem in the windows event viewers and I found this errors: Log Name: ApplicationSource: Application ErrorDate: 9/26/2023 12:16:47 AMEvent ID: 1000Task Category: (100)Level: ErrorKeywords: ClassicUser: N/AComputer: OPC_SVRDescription:Faulting application name: server_runtime.exe, version: 6.5.829.0, time stamp: 0x5b22a6cfFaulting module name: ge_ethernet_global_data.dll, version: 6.5.829.0, time stamp: 0x5b22a6dfException code: 0xc0000005Fault offset: 0x000245e8Faulting process id: 0xa48Faulting application start time: 0x01d9efa794a04a0aFaulting application path: C:\Program Files (x86)\Kepware\KEPServerEX 6\server_runtime.exeFaulting module path: C:\Program Files (x86)\Kepware\KEPServerEX 6\drivers\ge_ethernet_global_data.dllReport Id: c70f0f78-fd9b-4a8f-9cf8-92e647f4b643 Thi
Dear Community,yet another question for you; regarding the Beckhoff TwinCat driver;I only want to import OPC Variables which I have marked/commented in TwinCat.I commented them as intented for the OPC-Import:(*~ (OPC:1:available for OPC Clients)(OPC_PROP[0005] : 1 : read only)*)Unfortunately, when I import the device with"Respect OPC Read/Write Item Properties", "Respect Tag Case On Import" and "Only Import Variables Marked for OPC" enabled no tags at all are created.Why? Am I doing something wrong? I do not have any additional filters configured.Thanks in advance for your help.Kind regards,Kepware User
Dear Kepserver,I'm enounter problem in data logger with error Date Time Level Source Event02/10/2023 09:34:49 Error Data Logger Plug-in Unable to query recordset on Log Group 'Glass_Data'. Reason: sp_cursor: The value of the parameter 'value' is invalid. I check the value which generated default and only rename the " value name " and not for the data type. can you help me which can cause error?
Hi, my name is Ben Lau, the Project Engineer from a System Integrator in Hong Kong. I would like to communicate with the Johnson Controls NAE and Schneider SmartX controllers through BACnet I/P driver of your KEPSeverEX software. However, I have difficulties in configuration details: When attempting automatic tag generation for a node under Schneider SmartX Controller, the diagnostics window displayed completed status (only built-in tags generated by KEPServer BACnet I/P driver is available) but the following two warnings:"Error reading segmentation supported from remote device. Segmentation will not be supported.""Error reading object list from device. | Class = '1 (Object)', Code = '31 (Unknown Object)'." When attempting automatic tag generation for Johnson Controls NAE Controller, the diagnostics window displayed "Unable to generate a tag database for (Device Name). The device is not responding.".Please refer to the attached screenshots for current BACnet I/P settings for
As per this topic: Hello all, I have the similar study but my first plc is control logic (see the screenshot). I still not able to define the device ID. can you please help?
Hi, i am using KEPServerEX 6, connected to Mitsubishi PLCs through Mitsubishi Ethernet Driver, Q Series Model. Total there are 5 connections with the same configurations and settings, and 4 are communicating fine. However for the remaining 1 PLC, i am able to ping to the IP address of the plc, but when i run the OPC Quick Client, i am getting Bad for Quality and Unknown for Value. However, occasionally i am able to get good quality with proper values from the plc. I would like to know how should i go about troubleshooting it, thank you.
I'm having problems troubleshooting an SLC5/05 tag syntax. I am using Open Addressing and both of my OPC UA utilities required imported tags. Any tools or utilities I can use?
Caution: Multiple licenses of the same product cannot be activated on one machine. Attempting to do so will result in the loss of the license. kepware como resolver? oque fazer quando aparece esta mensagem no kepware?
Dear Sir, I want to Copy a column in excel sheet with 1000 cell value to Siemens S7 1500(Excel => Kepserver Ex(DDE) => Siemens PLC ).the only way up till now for me i write 1000 tags 3 time manually one time to define Siemens PLC tags ,second time in DDE, third time define in advanced tags . so there's any way to assign 1000 tags for example as array or any way?. Best Regards, Ahmed Helmy
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.