Recently active
As a system integrator, I have no idea how many Kepware licenses I've sold to clients over the past 20+ years. Two weeks ago, I was able to log into MyKepware account, open a support ticket, browse the knowledgebase, download software. Now, I can't do anything. Hoping that somebody in eSupport sees this. It says: Access Denied - Insufficient Privileges You are currently setup with a Basic PTC.com Account that does not provide access to this area of eSupport. This means that you may have an active PTC Global Support agreement however you have not yet Upgraded your Account to reflect your Support entitlements. To access this area please Upgrade Your Account. OK, so let's upgrade my account. Besides "upgrading an account is easy".. Bull**bleep**, I need a Customer Number, Service Contract Number, Sales Order Number or Security ID. I have none of those. My clients probably do. Good luck finding the person that knows where these are. I can log into the server an
I have thingworx 9.3.8 working normally. I need to install rttpm app. When I use the program "install-tw-apps-win.exe" the following error appears: "Service call failed with status code 502 - Could not connect to environment: self signed certificate". I checked article CS375802 - "Service call failed with status code 502 - Could not connect to environment: self signed certificate" error when installing ThingWorx Apps, but I couldn't go any further. Could someone please tell me what steps I have to do? For reference, below are the questions and answers given during the installation attempt, as well as part of my server.xml file. - install-tw-apps-win.exe installation (questions) ThingWorx URL (localhost:8080):Does ThingWorx use TLS (y/N): N " -> I tried with "y" too. Got the same error..."ThingWorx Admin Username (Administrator):ThingWorx Admin Password: Attempting to connect to ThingWorx server... Service call failed with status code 502 - Could not con
How do I set up a Chart like this? No Widget seems to have functionality close to this.
Hello all, My team and I have gotten LDAP working via an ActiveDirectoryDirectoryService, but need to be able to validate another user's non-admin credentials with LDAP, without logging the second user in. What services exist for manually validating an LDAP credential? We've tried the TestConnection, GetDomainGroups, and IsValidGroup services on the ADDS with admin and personal credentials, and they only work for the administrator.
If same user logged in with multiple session in different PC’s can cause this slowness?Thingworx v9.0
Hello, I want to a create new custom thing template extension using Java. so there is any document or any resource that is useful, I want to a create custom thing template to connect with Modbus PLC and read/ write data. I need guidance to create a custom thing template extension using Java
As subject, I would like to import adaptive sampling on Thingworx before transporting the data into DataBase, or the other way is adaptive adjust the interval of data consumption?
Hi experts,we use this service as described in Article - CS259031 (ThingWorx 9.1.14) but in some cases, there are files with a comma in its filename. This throws an exception like "JavaException: java.lang.Exception: Some files listed are not readable: [/24043033da000.iam/0, 7.ipt]". The real filename is "0,7.ipt" (without blank).The comma is used as separator like in the given example to create the list of filenames in var params. So is there any other way create this list without relying on special characters allowed for filenames? We need this feature because we want to exclude specific files from the list to be not included in ZipArchive.Any proposal appreciated - Thanks!
Hello, have you solved the problem? I have also encountered the same problem
I have a problem with KEPServerEX and inputs.opcua telegraf.I collect data with kepware use telegraf inputs.opcua. When I use advancetags/tags with good quality, I don't have problem. The problem is when the quality of advancetags/tags changes to bad (for example, driver stop working). My Kepware after a few minutes or seconds (no rule) stop working (My dataLoger no sent to sql and opcua no work). Application can't start(I click on it, it load, but the project never compiles), only reset server or service runtime to fix it. Off course, I don't have any event log about this problem. Where is problem...?I test with: kepware version 6.9/6.13Telegraf version 1.24/1.25/1.26
Hello, is there a way to disable the certificate verification on startup for Kepserver 6.8 so that I will not get error message like this "The UA Server certificate is expired. Please use the OPC UA Configuration Manager to reissue ... "
Hi All, What do the following property qualities represent on Industrial Things: Unknown, Good, Bad. Regards.
Hello, Yes it is not enough. Could you find the info about the possible values for the "fillOption"? Thanks
https://www.ptc.com/en/support/article/CS325300 reports on a problem with MQTT we are experiencing too (in Thingworx 8.5). In SSL mode, getting "the specified SocketFactory type does not match the broker URI".That article says "Corrected in MQTT Extension v2.1.2". However, the latest version available for download for TWX 8.5 is 2.1.1. Where can we find 2.1.2 ?
Hi, I am currently configuring some Advanced Tags in Kepware and I would like to round up some of the values that come up from the machines. For example, if it is 35.5 , round it up to 36 and ranging from 35.1 to 35.4, round it up to 35. Is there a way to do it? What we are looking for is a function or formula to round up a number with standard procedure.When it is 35.5,35.6,35.7,35.8,35.9, round it up to 36.When it is 35.1,35.2,35.3,35.4 , round it to 35.
Hello All, I wanted to download external file in twx repository using service so basically i need code snippet to download this file in TWX Service using link and save to repo Any help appreciated !
I have six WorkUnits configured in RTPPM, but the only one who calculate the OEE is the Machine1, all the others machines don't calculate and i don't know why because it looks like the rest is normal. This is the most current error: [PTC.SCA.SCO.MnfgCommonEquipmentUtilsThing].[SetUserDefaultSelectedEquipmentsBySolution_EQT]: Returned the following error : JavaException: com.thingworx.common.exceptions.ModelAccessException: [2,000] Error occurred while accessing the model provider. I will be greatful if someone can help me.
Software versions: TWX 9.1.14, MFG apps 9.1.1 Hello all, My team and I have successfully set up an Active Directory Directory Service (ADDS), so that users log in with their AD credentials, over an LDAPS connection. We also need to validate a second LDAP user, without logging out and back in. We've tried using the TestConnection Service, but always receive the result of "Unable to decrypt password". See code example below, where we pull all of our inputs from the (still working) ActiveDirectoryDirectoryService: let table = DirectoryServices["ADDS1"].GetConfigurationTable({ tableName: "Connection" /* STRING */});result = DirectoryServices["ADDS1"].TestConnection({ server: table.server /* STRING */, password: table.adminPassword/* STRING */, protocol: table.protocol /* STRING */, port: table.port /* INTEGER */, userName: table.adminPrincipal /* STRING */}); How do we encrypt the password so that the LDAP server is able to recognize
Hello, I have the Thing which is connected to the mysql database and I am able to retrieve the data to the thingworx mashup by writing the services in the database thing. So now i need to get the parameters value of the mysql database table in the generic thing where the properties .are there instead of getting the data from the database thing by fetching the data through the services , can we get the parameters values into thing properties which should be updating every time when the new data is logged in the database. If anyone have tried this, please help me to sort out this issue. Regards, Shree
We get timeout issues when we try retrieve a lot of data from a value streams. This causes the service to fail, and then data cannot be displayed in the mashup.1. How can we improve our services that use queries to handle large value streams?2. Are there limits for the size of the query it should stick to that ThingWorx can handle?3. Are there settings we can configure in Influx or ThingWorx to improve the performance or allow larger queries?4. What best practices can we use to handle large data queries?5. Sometime we see that in the Dev tools network monitor that a service will fail before it reaches the 30 second timeout, is ThingWorx estimating how long it will take and then stopping it running? Some of the errors we are getting from the application logs:1. We get an error 2006 - lnfluxdb2DataExceptionTranslator2. Execution error in service script [*****] :: com.thingworx.common.exceptions.DataAccessException: [2,006] 3. Unknown error occurred. Contact the administrator if this
Hello, I have try to install DPM using Solution Central Subsystem but getting error regarding license so how to know which license required for DPM and how to solve this error
As per this thread - same issue Hey @IMM, Did you manage to access those adresses ? I have the same issue. Best regards
Is there any ThingWorx built-in API or services for data hygiene?
In mailserver thing, I need to update/change the configuration by using java script coding. How to do that?
I want to create a mashup in which I take value from a label, then run a service to manipulate the data and finally display it on another value display widget. But I dont know how to do this.If anyone has some documentation related to this please share. Also let me know where I can learn about services, services creation using javascript and all its function.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.