Recently active
Hi Everyone, I am building some custom reports using Thingworx and FlexPLM query builder in QBR I have some 80000-1000000 data I am fetching these records but I am getting time out issue so what time shall I set for the script time to fetch the data default Timeout is 30 second.Error: "Execution of Script terminated after : 67 seconds. Timeout configured for 30 seconds."For this I need to increase service execution time for this 2 approaches I know :1) Sql Service ---> Service Info ---> Time out Interval (sec)2) Platform-settings.json ---> define script Time-outHow can I decide the timeout duration Please suggest some steps if anyboday have any idea?or tell the value .Thanks and Regards,Lav.
I was working with Kepware on a problem and during the discussion we enable a trial of IoT Gateway. I wont be using it in my application. But now it is filling my event log with "Time limited usage period on feature IoT Gateway has expired." Also, while on a trial of KepServer and this IoT Gateway, a notification shows up every 30 seconds to tell you it is a trial with limited time. It was so distracting I just uninstalled the software and work remotely with the actual licensed software. Now I just need to get rid of the IoT on that. Thanks, Scott
When I click on "Launch Quick Client Here" the quick client opens showing 640 tags. Most of which are unwanted. I have the timestamp for the opening time, quality Good and Update Count 1. All but two of the update count values remain at 1 and the time stamps for those value remain at the starting time. Two tags are updating every couple of seconds. Of the rest of the tags 7 are marked Bad. In the KepserverEx event log there are 12 tags marked "Unable to read tag" with a CIP Error = 0x5. Am I really getting data from the PLC? How can I tell if this is accurate? How do I make the other tags update like the two anomalies? KepserverEx 6.14.263.0Thanks for the help.
I have temperatures 10 times higher than they should be. I read the article "How to scale data from a PLC in PTC Kepware Products" (https://www.ptc.com/en/support/article/CS291338). It resulted in a tag that errored out with a CIP error 0X5.I created the new tag, gave it a name and description and the address. and set the Scaling to linear, 0 to 10000. And got the error. I tried changing the data type from Word to Float and Short, but they threw the error for illegal data type. Any other suggestions? Scott
Hi All var input = '0xFFD8FFE000104A46494600010100000100010000FFDB0043000201010101010201010102020202020403020202020504040304060506060605060606070908060709070606080B08090A0A0A0A0A06080B0C0B0A0C090A0A0AFFDB004301020202020202050303050A0706070A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0A0AFFC0001108025F043803012200021101031101FFC4001F0000010501010101010100000000000000000102030405060708090A0BFFC400B5100002010303020403050504040000017D01020300041105122131410613516107227114328191A1082342B1C11552D1F02433627282090A161718191A25262728292A3435363738393A434445464748494A535455565758595A636465666768696A737475767778797A838485868788898A92939495969798999AA2A3A4A5A6A7A8A9AAB2B3B4B5B6B7B8B9BAC2C3C4C5C6C7C8C9CAD2D3D4D5D6D7D8D9DAE1E2E3E4E5E6E7E8E9EAF1F2F3F4F5F6F7F8F9FAFFC4001F0100030101010101010101010000000000000102030405060708090A0BFFC400B51100020102040403040705040400010277000102031104052131061241510761711322328108144291A1B1C109233352F0156272D10A16243
Hello, I have some difficulties trying to run android java sdk setam sensor sample. 1-Donwlod the java sdk from official website 2-Since the gradle version is 6.3 , I downloaded the compatible jdk (version 14) 3-Import the project from android studio 4-Configure gradle with my JDK (see pic1) 5-run .\gradlew assemble (see pic 2) 6- Output error (see pic 3 for full error): Duplicate class ch.qos.logback.core.util.StatusPrinter found in modules logback-android-core-1.1.1-6.jar (com.github.tony19:logback-android-core:1.1.1-6) and logback-core-1.3.14.jar (ch.qos.logback:logback-core:1.3.14) Duplicat.... I tried to fix on build.gradle file but it didn't work. Some classes are declared twice in two different jar files... I add my 'build.gradle' Any ideas Thank you.
Dear all,as explained in the Subject there is a problem with the Runtime automatically booting up in Kepserver 6.16.This article applies to 6.15; this solution doesn't work for 6.16.Article - CS412894 - Unable to boot KEPSeverEX 'Runtime service' without manual intervention (ptc.com)Does anybody know to fix this?Kind regards and thanks in advance
In previous versions of TWX, the mashup was working fine. But when I was trying to load the Mashup in the Thingworx 9.3.4 version, the mashup doesn't show any widgets, only empty Screen can be seen!In Console, I saw following error: Note: Mashup contains Custom widgets. Thanks,
Hello, When using the Media Queries, the pop-ups are not getting center aligned...The following code for the Media query has been used in the mashup Thanks,
Hi Everyone,I am very new to OPC UA Security Policies, currently using KEPServerEX and would like to know if it supports integration with an OPC UA Global Discovery Server (GDS) for managing certificates. Specifically, I have the following questions:Does KEPServerEX support GDS? If yes, how can I set it up to work with a GDS to manage OPC UA certificates?Certificate Management for Multiple Clients: I have hundreds of OPC UA clients connected to my server. What is the best way to manage certificates for these clients?Handling Certificate Expiry: If multiple client certificates expire simultaneously, how can I manage this scenario effectively? Is there a way to automate the renewal and distribution of these certificates through GDS or any other method?Any guidance, best practices, or step-by-step instructions would be greatly appreciated!Thank you in advance for your help!
Goal: I have multiple OPC UA Clients who will connect to the OPC UA Server (Kepserver). Trust every client is getting difficult. I cannot make the Security Policy to "None".I have created a common CA. Created a server pfx file and imported in Kepserver in OPC UA Configuration Manager>Instance Certificates. Imported the CA.dar file in Trusted Client List.I have created certificates and private keys for Uaexpert and signed them with the same CA.Created CRL and pasted in C:\ProgramData\Kepware\KEPServerEX\V6\UA\Server\crlStill I am facing problem while connecting.Is it possible to do this? Is there any other process to achieve the goal? Please guide me.
Hi, I have an extension which contain one service where data from csv file is loaded into an infotable and service return type is infotable. Service throws custom exception if anything fails or data is not valid in csv. In thingworx, I am calling the extension service using a snippet service, now I need to validate the service response whether the response contains an infotable or is an error message returned from the service. Incase of error, I need to show it on mashup to end user. The issue is how to validate the response whether its an infotable or an error message. Appreciate help in advance.
Hello Developers, I m trying to install Thingworx analytics server -9.6.1 on my windows .but getting error below like:-I installed java jdk 11.0.12 and also configured successfully. before installation of the thingworx analytics server I used ThingWorxFoundationMSSQL-9.3.9-x64 in my system and it works very well, however after the uninstallation of ThingWorxFoundationMSSQL-9.3.9-x64 and trying to install Thingworx Analytics server --getting above error. please provide a solution on this. Thanks
I downloded the last version of Java sdk thingworx (7.0.2) and I am trying to build the Android-Steamsensor sample. I am following this tutorial (3 steps):https://support.ptc.com/help/thingworx/edge_sdk_java/en/index.html#page/java_sdk/c_android_sdk_samples_build_cmd_line.html#wwID0EOLIO I run gradle.bat assemble => Output: Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.Use '--warning-mode all' to show the individual deprecation warnings.See https://docs.gradle.org/6.3/userguide/command_line_interface.html#sec:command_line_warningsBUILD SUCCESSFUL in 740ms According to the tutorial, this command produces your ready-to-deploy apk files in the subdirectory, build/outputs/apk. However there nothing ! Any idea ? Thank you for your help
I provided text field widget with Mask Number. This field is displaying '-' symbol as default. Whenever I typed first digit the symbol '-' replaced with digit. But if the digit value passing from binding, then this widget is displaying '-9' Even though if the passed value is positive it is showing the digit after the symbol -. As i dont have option to use disable property in numeric entry widget, i have to go ahead with textfield with mask. Kindly tell me how to overcome this symbol - when numeric value is passed from parameters.
I have used KepServEX for many years without issue - but running the latest version for some reason the I/O addressing is backwards. Digital Inputs are controlled with %Q - does anyone know why this is occuring?
when I used KEPSERVEREX 6.16 for customer First it failed to automatically tag generate device (ODBC client), than I search in the community, follow the instruction, change settings about runtime process from system service to interactive mode; it can generate the tags of ODBC client. Second I see the service of windows no runtime service, then when windows lock or log off the system automatically it will kill the application but not the service of windows, So are there any solutions to solve it?
Hello, For best practice reason, I am trying to install a second thingworx database for my project.I will have a first database dedicated to my thingworx instance.All data (stream, value stream , datatable..) will be installed in separated database : 'project_db'So the idea is to use thingworx script to install the second database, i am using this article as a starting point :https://www.ptc.com/en/support/article/CS262935 the scripts are:thingworx-model-schema.sqlthingworx-property-schema.sqlthingworx-data-schema.sqlthingworx-grants-schema.sql My questions are : Do I need to install all thingwrox db scripts to install the second database, or I just need to install only thingworx-data-schema.sql script since we only need to store data ?If I have to install only thingworx-data-schema.sql, I notice a lot of table created ? Do I need them all or just a few tables? Can I clean the database and keep only needed tables, if yes witch tables should I keep ?The art
Hello,I have two thingworx (9.3.4) running on 2 differents containers.1- Container 1 is configured on port 80:8080 (NO_TLS = TRUE)2- Container 2 is configured on port 8081:8080 (NO_TLS = TRUE)From my host machine, i run an edge csdkit works perfectly with the first container (port 80) [See log OK]With the second container, i have an error TW_NEW_SSL_CLIENT: SSL handshake error. Consider verifying you have compatible SSL ciphers, Error was: error:0A00010B:SSL routines::wrong version number. [See log KO]I tried to update the configuration of tomcat but it didn't work Do you have any idea how to use any port except 80 to run the edge Thank you for your help.
Hi, I have installed the Thingworx on 8080, but I want to run it on 443, 8080 (HTTP) and 51366(HTTP). I have changed in the server.xml, but it fails when I add two more connectors: Output of Catalina.out 13:24:47,593 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback-test.xml] 13:24:47,594 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback.groovy] 13:24:47,594 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Found resource [logback.xml] at [jar:file:/opt/ThingWorxFoundation/tomcat/apache-tomcat-9.0.52/webapps/Thingworx/WEB-INF/lib/thingworx-platform-common-9.3.0-b20.jar!/logback.xml] 13:24:47,616 |-INFO in ch.qos.logback.core.joran.spi.ConfigurationWatchList@5734eaa7 - URL [jar:file:/opt/ThingWorxFoundation/tomcat/apache-tomcat-9.0.52/webapps/Thingworx/WEB-INF/lib/thingworx-platform-common-9.3.0-b20.jar!/logback.xml] is not of type file 13:24:47,659 |-INFO in ch.qos.logback.classic.j
Hello,I would like to receive at the exact same time all the tags values from a data logger when one of the value of the list of tags change. To do so, I tried to use the 'Log on data change' from the Trigger but sometimes I have a delay.Do you know what I could change in the parameters of the data logger to receive all the tags at once ?
I am using ThingWorx Platform Release 9.3 and DatecodeSP5We are getting authentication errors intermittently on Edge and Chrome browsers with SAML. This happened over the weekend after a year or more of successful SAML authentication in those browsers. We resolved the issue by increasing the value for "samlAssertionMaxAuthenticationAge" in the sso-settings.json file but still don't understand why the issue started. Can you provide help with understanding what caused this issue to help prevent it in the future?Here are the errors that I faced[ Error validating SAML message ][ Response doesn't have any valid assertion which would pass subject validation ][ Authentication statement is too old to be used with value
Hi, I have a datatable and one of the field is of type PASSWORD , now i edit the field and choose string for it and i can see encrypt value of this field ...and i am saving the value in datatable using Resources["EncryptionServices"].EncryptPropertyValue(params) and now i want to see the original values of these fields. Is there any way that i can see the original values? I have written a service to get the entries as a REST API and then iterate each entry and get the field password as one long string and using ACCEPT / also but for me its still coming the same encrypted values what it shows in datatable. my code to add password result.AddRow({loginName: loginName.toUpperCase(),firstName: firstName,lastName: lastName,language: language,emailAddress: emailAddress.toLowerCase(),hashedLoginName: me.SHA256({toHash: loginName.toUpperCase()}),groups: groups,loginPassword: Resources["EncryptionServices"].EncryptPropertyValue({data: me.SHA256({toHash: loginPas
my thingworx analytics tab can't load dataset
I have a use-case where in users want an option to change languages at runtime but not using the Runtime overview OOTB option of ThingWorx. Has anyone implemented or worked on similar use-cases.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.