Take the Windchill Satisfaction Survey!
Recently active
I see that AB has Ethernet IP based IO called the 1732 family.They are industrial, hardened IO that seem perfect for the shop floor.dsI'd like to be able to connect these directly to the Kepware Server.IS THERE A KEPWARE DRIVER THAT CAN TALK DIRECTLY TO AB ETHERNET/IP BASED IO?Thanks.
I was working with Kepware on a problem and during the discussion we enable a trial of IoT Gateway. I wont be using it in my application. But now it is filling my event log with "Time limited usage period on feature IoT Gateway has expired." Also, while on a trial of KepServer and this IoT Gateway, a notification shows up every 30 seconds to tell you it is a trial with limited time. It was so distracting I just uninstalled the software and work remotely with the actual licensed software. Now I just need to get rid of the IoT on that. Thanks, Scott
When I click on "Launch Quick Client Here" the quick client opens showing 640 tags. Most of which are unwanted. I have the timestamp for the opening time, quality Good and Update Count 1. All but two of the update count values remain at 1 and the time stamps for those value remain at the starting time. Two tags are updating every couple of seconds. Of the rest of the tags 7 are marked Bad. In the KepserverEx event log there are 12 tags marked "Unable to read tag" with a CIP Error = 0x5. Am I really getting data from the PLC? How can I tell if this is accurate? How do I make the other tags update like the two anomalies? KepserverEx 6.14.263.0Thanks for the help.
I have temperatures 10 times higher than they should be. I read the article "How to scale data from a PLC in PTC Kepware Products" (https://www.ptc.com/en/support/article/CS291338). It resulted in a tag that errored out with a CIP error 0X5.I created the new tag, gave it a name and description and the address. and set the Scaling to linear, 0 to 10000. And got the error. I tried changing the data type from Word to Float and Short, but they threw the error for illegal data type. Any other suggestions? Scott
Dear all,as explained in the Subject there is a problem with the Runtime automatically booting up in Kepserver 6.16.This article applies to 6.15; this solution doesn't work for 6.16.Article - CS412894 - Unable to boot KEPSeverEX 'Runtime service' without manual intervention (ptc.com)Does anybody know to fix this?Kind regards and thanks in advance
Hi Everyone,I am very new to OPC UA Security Policies, currently using KEPServerEX and would like to know if it supports integration with an OPC UA Global Discovery Server (GDS) for managing certificates. Specifically, I have the following questions:Does KEPServerEX support GDS? If yes, how can I set it up to work with a GDS to manage OPC UA certificates?Certificate Management for Multiple Clients: I have hundreds of OPC UA clients connected to my server. What is the best way to manage certificates for these clients?Handling Certificate Expiry: If multiple client certificates expire simultaneously, how can I manage this scenario effectively? Is there a way to automate the renewal and distribution of these certificates through GDS or any other method?Any guidance, best practices, or step-by-step instructions would be greatly appreciated!Thank you in advance for your help!
Goal: I have multiple OPC UA Clients who will connect to the OPC UA Server (Kepserver). Trust every client is getting difficult. I cannot make the Security Policy to "None".I have created a common CA. Created a server pfx file and imported in Kepserver in OPC UA Configuration Manager>Instance Certificates. Imported the CA.dar file in Trusted Client List.I have created certificates and private keys for Uaexpert and signed them with the same CA.Created CRL and pasted in C:\ProgramData\Kepware\KEPServerEX\V6\UA\Server\crlStill I am facing problem while connecting.Is it possible to do this? Is there any other process to achieve the goal? Please guide me.
I have used KepServEX for many years without issue - but running the latest version for some reason the I/O addressing is backwards. Digital Inputs are controlled with %Q - does anyone know why this is occuring?
when I used KEPSERVEREX 6.16 for customer First it failed to automatically tag generate device (ODBC client), than I search in the community, follow the instruction, change settings about runtime process from system service to interactive mode; it can generate the tags of ODBC client. Second I see the service of windows no runtime service, then when windows lock or log off the system automatically it will kill the application but not the service of windows, So are there any solutions to solve it?
Hello,I would like to receive at the exact same time all the tags values from a data logger when one of the value of the list of tags change. To do so, I tried to use the 'Log on data change' from the Trigger but sometimes I have a delay.Do you know what I could change in the parameters of the data logger to receive all the tags at once ?
Hey there, First I want to say that I am rather new to this, just learning my way through an existing system. I don't know a ton about APIs or KEPServer. I've been tasked with taking wireless sensors and retrieving their data through Rest API. The sensors are known as Alta Monnit Sensors. Their web portal showcases a way to retrieve data this way. They also have a guide on how to receive the data utilizing Postman Now I believe what I want to do is create on IOT Gateway Agent, use "https://www.imonnit.com/json/SensorGet?sensorID=1220966 " as my URL, POST as my method. However from here, if I'm on the right track, I'm not sure how to get the data into tags. Any advice?
Hi all,I am currently working on having a manufacturing execution system (MES) my company uses to writeback values to one of the PLCs it talks to. Our MES is on a virtual machine, let's call it APP014 & Kepware is also installed on this server. RSLinx/our OPC topic configuration is held on a separate server, called "GE".Our current communications configuration is using Kepware as a middleman to talk to RSLinx (in other words, Local Kepware to Remote RSLinx) so that we can retrieve tag values from our PLCs. This is done as a read only process; we are using these tag values to provide real-time data to our MES. However, OPC writeback has never been implemented.Contacting the OEM of the MES, I am able to writeback tag values to the Kepware OPC server, but I would need a separate functionality that writes the values from the Kepware server back to RSLinx, in order to edit tags in the reverse.Does anyone know a way to perform this?Thanks!
Dear team, I have one query, want to covert binary data from the PLC or OPC 16 bit data word. Is it possible in Kepware using any Advance tag or other driver plugin?
When I open KEPServer it gives me an error that says "Connection attempt to runtime failed" in the event log. Then it times out and gives me a dialog box asking if I want to work offline. The latest project was not showing. I tried to open the project, but it had not been saved. So I tried to open an older project. It opened and I tried to connect the runtime and again it failed. I checked Task Manager and the runtime is running. I updated the license an hour ago. I got a "Success" dialog box. Does anyone know what is going on and how I overcome this problem? Thank you, Scott
I'm having problems connecting KepserverEX v6.1 to Thingworx v9.3 I can confirm that the pc that kepware is installed on can see the Thingworx server (I'm able to access composer and port query confirms port 443 is open). Thingworx’s Industrial Thing’s Base Thing Template is set to “IndustrialGateway” and the appkey is correct. I have also tried both Host name and IP of the server. This issue is effecting 2x clients both running kepserver v6.1, the reason for the low version number is that both clients were setup 5 years ago to run an Etch line and Penetrant line and we are only now wanting to connect them to Thingworx. Unfortunatly the OEM who did the initial install has gone bust so I'm unable to raise suport ticket via them
Looking for a better understanding of the error we encountered in Kepware: "<DEVICE> | The following errors occurred uploading controller project from device. Resorting to symbolic protocol." We had an issue in our plant where connectivity between Kepware and several Allen-Bradley PLCs were dropping out intermittently due to a networking issue. Approximately 3 minutes after this event started, we saw the above error message posted for all PLC's involved. While the message states the "following errors occurred" we never saw an actual message with details. Just the line above. For context, all PLC's involved were originally setup with Logical Non-Blocking addressing. Kepware changing/resorting to using Symbolic addressing appears to have overwhelmed a combination of the PLC, network and driver. We were unable to recover until we restarted the Kepware server. We've seen Kepware make the switch to Symbolic addressing when
Does anyone know if there is a way to export the asset inventory from Kepserver? Looking specifically for a list of the devices at a site with their name, IP and/or MAC address, and anything else we can get. Would be interested in the API call as well if there is one.
When communicating with Mitsubishi PLC via Mitsubishi Ethernet from kepServer, I wonder if it is difficult to link if they are on different networks.I have already confirmed that linking is possible on the same network.----------------------------------------------------------Translated the topic from Korean to English using google translate.Body - kepServer에서 Mitsubishi Ethernet을 통해 Mitsubishi PLC와 통신할 때 다른 네트워크에 있으면 연동이 어려운지 궁금합니다.같은 네트워크에서 연동이 가능하다는 것은 이미 확인했습니다.-By Community Moderation Team.----------------------------------------------------------
Hello community, We're experiencing issue where errors attached bellow pops up and it seems like this problem causing outages in our MES visualization system. Any ideas what can cause this error message or how to deal with it? Thanks in advance for suggestions. JT
I have a problem about I changed the location of KEPSeverEX from PC-A to PC-B I transfer the licence and save lic file and active with new PC -B but I can't connect to my PLC and it still show time limit ( I can monitor some data ) how to solve this problem please suggest. Thank you in advance.
Hello Team, I would like to read the value from configuration API service, How can read the Value?
I'm not even exactly sure how to ask this question so if I seem ignorant that's only because I am. I assume that I'm having an issue understanding a fundamental concept of interacting with an OPC UA server. I'm attempting to create an OPC UA client in Python to ultimately read values that originated from Modbus PLC registers. The targeted PLC is successfully connected to KepServerEX6 and values from registers are being pulled into KepServerEX Project>Channel>Device>Tags perfectly. The data (values from PLC registers) is being and has been successfully used from this KepServer by another application for several years so KepServer and connections to multiple PLCs (multiple brands) is working just fine. Python code completely aside, in a 3rd party OPC UA client application (UaExpert), I can connect to the OPC UA server, I can see a lot of things about the server/KepWare, (Root/Objects/Server, ServerCapabilities, ServerDiagnostics, etc) but the Objec
I am using KepServerEx (version 6.16) OPC DA client to access ABB MicroSCADA OPC server data.I am able to access OPC tags using the connection parameters. But when trying to read data using the OPC channel, i am getting the BAD vartype errorPictures (1-5) If I directly add OPC server to OPC client, and import tags to it from the same server, i am able to read all the values.Pictures (6-7)
Hello community,Is there a way to check what the real error is in KEPServerEX for SQL diagnostics? This doesn't help at all:Date Time Level Source Event12/08/2024 16:39:18 Error Data Logger Plug-in Unknown error while executing query in table 'mytable' for log group 'datalog-azure'. I am guessing it's something about security/privileges since I am trying to log data in an Azure database.I am able to see tables, columns when I am mapping the data but unable to write values to table.Using app version 6.16 (V6.16.203.0) Any help is appreciated. Cheers,
I am trying to configure Datalogger and keep running into issues in the configuration. I have created my DSN correctly and it successfully passed the connection test. But whenever I try to select the table name, the dropdown list does not show any of the tables in my database. I attached a screenshot of what shows up in the dropdown.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.