Take the Windchill Satisfaction Survey!
Recently active
In kepware there are energy meters tags showing tag quality good but values are shown as zero. All of changes in setting like reducing block size, recreated channel and devices, restarted kepware number of times we got bad address in block error. kepware error guide saying below reason,Possible Cause:The driver attempted to read a location in a PLC that does not exist, perhaps out of range. For example, in aPLC that only has holding registers 40001 to 41400, requesting address 41405 would generate this error.Once this error is generated, the driver does not request the specified block of data from the PLC again. Anyother addresses being requested from this same block are considered invalid.Kindly anyone post a solutions for the above problem.
Q-series Mitsubishi PLC connected to two Kepservers. One is KEPServerEX v6.14.263.0 and another one is Thingworx Kepware Server v6.14.263.0.I am receiving data from PLC in KEPServerEX v6.14.263.0 but not in Thingworx Kepware Server v6.14.263.0. all the channel and device configuration is same.Communication is having TCP connection and port number is 10000 in mitsubishi PLC and same at server side.earlier I was able to receive the data in both the servers.How can it be resolved?
We are getting "Request pending" from Kepware IoT Gateway REST Server.We have configured almost - 10000+ tags for each site. We have CPU utilization remaining below 30%, indicating sufficient processing capacity for additional tasks. Network bandwidth is available, confirming that communication delays are not related to data congestion. We have only a single Kepware for all the sites. Does it going to impact our solutions?
Hi all, I am trying to import some OPC UA tags into Kepware via CSV. I have an address that looks like the below which is the address value in my CSV file: ns=3;s="DB31 Data Fixture"."CurrentMoldType" But when I import it the address ends up like this in Kepware:I can't seem to figure out why it is ending up with "" in Kepware when it isn't like that in my CSV
I am using KepwareEx6.15 with Mitsubishi iQ-R32 PLC + RJ71EN71 module.Kepware Channel and Device configuration point out to the RJ71EN71 module (SLMP TCP/IP port)I have created SLMP TCP/IP 40 ports for connecting the same PLC+RJ71EN71 module with KepwareEx6.15 multiple channel and devices for limit the tags in each devices for quick poll. I have active client connections with KepwareEx is 120 and Active tags more than 3000 with scan rate 100ms. I am facing the challenge to write back 200tags values from kepwareEx to PLC it took more than 40 secs. the below information were my testing observations. Scenario 1: When i restart the Kepware and disconnect the active client connections and maintain one channel & device with 200 tags the write back time is 6secs. Scenario 2: When i restart the Kepware and loaded the active clients connections and maintain the one channel and device with 4000 tags and write back time of 200 tags is 60secs Scenario 3: Whe
Hello, We are working on a project where we aim to collect PhD data using Kepware and transfer it to Apache Kafka. Since Kepware doesn't have a direct integration with Apache Kafka, we designed an architecture where we send the data to an MQTT broker (Mosquitto) and then use Node-Red to forward it to Apache Kafka. However, we're unsure if this is the best approach.We're currently in the testing phase, but as the number of tags increases, we’re encountering some issues with Node-Red. The data is not being transferred properly to Kafka, and we are getting some buffer errors in Node-Red. By the way, we are using Node-Red as a MQTT connector, and while there are many other connector services available, We preferred the open source one.. We are working with approximately 60,000 tags, and our goal is to send the data to Kafka in 1-minute intervals.How can we successfully implement this project? Have there been any similar projects done before? If you need more information about the
Hi Team, I have approximately 2000 tags configured in the KEPServerEX Mitsubishi PLC Channel. When I open the Quick Client, all tags show good quality and actual values. However, I am now looking to write or change the value of all 2000 tags at once, instead of selecting and entering values for each individual tag manually.Could you please advise if there is an easy way to update all the tags in bulk within KEPServerEX or Quick Client? Any recommendations for handling this in a more efficient way would be highly appreciated.
Hi Team, How can we check the number of tags available in an individual device in the attached configuration type.
Hello, I am attempting to create a new channel and I want to define the Beckhoff TwinCAT driver communications, but I do not see it in the list of driver options. How can I obtain Beckhoff TwinCAT driver? Can it be applied to an existing version of KEPserverEX that does not have it, or does the KEPserverEX software require update to another version? I greatly appreciate the help here, thank you all so much in advanced!
Hi all, I am working on a use case using the kepware API to create kepware tags. Long story short, I want to create many tags with an empty/placeholder address and then can update the address at a later time as needed, but don't know what address will always be there regardless of machine that I can use. When I try to create a tag using the API with an address that doesn't exist it errors, which is why I am looking for a "universal address". I don't have much experience with PLC or address stuff so any help on this would be appreciated.
Does Kepware enterprise have MQTT Client Driver.Thanks
hi, am trying to connect to my webserver using IIOT Gateway pulgins Configured as REST SERVER,Since it was tested using HTTP during testing , it was working fine , While for Production we have to do it in HTTPS.I Am a not able configure it , Support needed.Thingworx Kepware SERVER EX V6.16.217.0As iam trying to upload SSL certificate, its showing format error.''Failed to import the Certificate. the format is in valid''
I'm using Ignition to read about 4800 values from some BACnet devices. The on site enteliWEB app shows values updating every few seconds. But it can take a minute or more before Ignition updates the value to something else. They almost never match as it takes too long to get the updated value from KEPServerEX. The default poll rate in Ignition is 250ms and in KEPServerEX the BACnet device is set to "Respect Client Specified Scan Rate" by default. I've also tried the "Request Data at Scan Rate" set to 100ms. The tags always seem to show their scan rate at 100ms.
Hi All - We are currently on Kepware version 6.7.1054.0Can you advise of which version of the application we can upgrade to, which is stable ? Appreciate the inputs! Thanks, Danaraj AG
Hello people, I am having a configuration as TIA portal - Kepware - Ignition 8.1 Perspective. All my tags are healthy, communication is established and data is reading as well as writing. I am facing an delay issue in this configuration, like when I write on any tag in Ignition or from Ignition to TIA through Kepware, it is taking much longer time to update that tag, almost 20 - 30 secs. If I read/write values on memory tags in Ignition or Simulate PLC in TIA portal, it is acting very normal, the response time is fast within the respective software. All my settings are as per required settings, scan time of Kepware is in msec. I am unable to figure out what is the issue with this.I am using License versions of every software. Please guide through this.
HI, we are connecting multiple Fanuc controllers (15i,16i etc.) to Kepware (V6) through Fanuc Focas ethernet driver. Currently getting 3 fault tags as Battery Low, Fan Alarm and Emergency. Are there other fault tags present for Fanuc controllers and how can we access them to Kepware server.Please guide. TIA.
I am reaching out to address an ongoing issue I have encountered with OPC UA tags in my system. Despite correct configuration on the client side and the camera software visibly indicating alarms, these are not reflected in the client’s system, suggesting a possible interruption in data transmission between our camera software (OPC DA standard), KepwareEX 6.16 (OPC UA standard), and the client’s software.Problem Description: OPC DA Client Reconnecting: The server on the 'Camera' channel is attempting to reconnect due to a GetStatus failure, this error is displayed in kepware. I also see this error: access to object denied. | User = 'Data Client' , Object = ' Camera.Aira' , Permission = Dynamic Adressing. I have enabled the IP address firewall to allow the OPC UA IP address, maybe not correct. I also made adjustments to alarm settings in the camera software's web application have not resolved the issue.Softing OPC Toolbox Diagnostic: Tags within the OPC server group display as half
Hi, Somehow, In my OPC UA server, all tags got 15 subtags. These subtags are not visible in Kep Quick Client or in the Kepserver Configuration Window but visible in UaExpert or other OPC UA Clients. I want to stop it. Please guide me how to deactivate this!Thanks in advance.
We know about Mitsubishi-Etectric series in Q series.Check the understanding of best practices in tags per channel on IoT gateways.What is the maximum number of tags on IoT gateways?
I add a area and source to validate Alarm and Event funciton with UAExpertA/E should be activated as wellBut in UAExpert, I can't see it and I can't find any access to see it, please give me a help here, thanks
Hello, I need to get some PLC Events data from an External OPC UA Server. If I am using UA Expert, we use the Event View to get the events, it shows general machine status which we need. Does KepServer have similar feature to read events from external OPC?
Hi I'm using Kepware KEPServer EX 6.16 and connect a Modbus TCP device. Data acquisition is ok and Datalogger in ODBC also is ok. The process is to acquire 3000 registers and archive in a Database. I noted that when Inter-Request Delay when is set to 0 the requests to the Modbus TCP device are very very high (higher then I need) but if I set to a number near the Scan Rate (5000 ms) of each tag I don't have all the value expected in database Static Interval (10 seconds), how can I set this parameter (or other) to have less query and stay to the Static Interval lapse? I don't have issue about timeout or delay in communications. Albe Best Regards
Hi Community, I'm working in evaluation where Kepware Datalogger send data to ODBC Postgresql driver a lot of data and after 1.5 milions of rows the data inserting stopped until I delete old values from destination table in Postgresql+Timescaledb. Does exist any limitation in trail license (moreover the expiring indicated in Events) ? I'm using Kepware KEPServer EX 6.16 Best RegardsAlberto
KepWare.KepServerEx.V6 The client connection has reach a limit. Then I increased the maximum to 2,000. The number of clients shown at bottom right conner is still increasing to reach a limit again while we don't have a number of clients about tens. How to disconnect inactive client automatically?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.