Take the Windchill Satisfaction Survey!
Recently active
I'm currently testing KEPServerEX 6 in a highly Mitsubishi Focused facility. We have many Mitsubishi PLC's but only six are on a ethernet network and are considered "Masters." The majority of the Masters are connected to other Mitsubishi PLC's via CC-Link IE-Field. I have been able to connect to one of the Master PLC's and create tags, data log to sql, etc. I am trying now to pull data (X's and D's) directly from a PLC on the the CC-Link IE-Field network. For example in the attached picture i'm trying to connect to W/S Station 8. In the Mitsubishi driver I have the ID set to 10.25.0.130:N1:8. The I.P. is the Built in Ethernet Port I.P. on the Master PLC which I can connect to just fine. Then N is Network 1 which is a CC-Link IE-Field Master Card on the Master PLC rack and 8 is Station 8 on the CC-Link IE-FIield. When I try to monitor those the tags in Quick Client I get this error.Date Time Level Source Event1/30/2023 12:32:29 PM Error Mitsubishi Ethernet Mitsubishi Q Series.Wast
Hi, We have a decision to make regarding choosing a tool for our next project where the ability to send data to a MQ is mandatory. Does anyone have the answer to the questions posted on this topic? Rui
Hello, I recently started a project with 7 PLC (Mitsubishi C2J). Each of the device has its own channel. When I launch the QuickClient, only the first device have its tags quality at 'Good'; all the other have bad quality. Also, in the logs, it appears that 'Device is not responding' for them. The strange part is that, when I ping the IP addresses of the devices, all of them are responding well. and the item ._system of the device that are not responding have ._Error boolean at '1'. The last thing that I have noticed is that, when I change the IP address of the first channel to another one (ie, from .31 to .32), the new address of the device becomes readable in the quick Client. I though it was an error in the channels parameters, but the all have the same parameters. Need some help, thank you.
Hi, Can Kepserver support calling and OPC methods and how would that be done? Is there any documentation on it - or it has to be done through other solutions. Thanks
I want to know what is the max count of channels (modbus TCP/IP Eth) I can configure in one Kepware Server Ex Instance ?. I want to be able to configure 60 channels to read around 84,000 data points on Modbus I also want to ask if 100,000 tags is the limit on how much one kepware server ex can read ?
Hi,From Derived Tags, we are getting negative values due to spikes in the signals; how can we avoid sending negative values from KepServerEx to Thingworx or any configuration that can be done from KepServerEx to avoid this or any change that can be done in the Remote Thing? Such that storing negative values on DataBase can be avoided.Thanks
Hi, I see this applies to KEPServerEX 5.20.396.0 to 6.12 What about the older version like 5.18? Any suggestions please? I cannot find any documentation from PTC.
I'm working on a system with around 12 Channels and different PLCs with different KEPServerEX drivers.We converted a PLC program to run on a test 1756-L73 ControlLogix 5570 controller. I only had to update the Wonderware InTouch tags items/addresses in the database from something like (B3:7/3) to (B3[7].3) and everything seemed to work fine.Now we have the production PLC and its a 1769-L33ER CompactLogix 5370 Controller. Again, everything seemed to work until we tried to write to an address in the PLC. All addresses can be read but the only way to write to an address in this PLC is to create a tag in KEPServerEX and use the OPC quick client to change the value. I can then change the item in the InTouch DB to the new test KEPServerEX tag and that will work.None of the existing PLCs in the KEPServerEX configuration have tags configured. Just changing from a ControlLogix to CompactLogix requires tags to be added into KEPServerEX but only for writes?I hope I'm missing a setting or somethin
Hello all, I tried to test KepwareEX 6.11 and find that TIA portal explorer hails that openness is not installed at the begining of explorer installation. I hope its only question of proper testing at this moment. Is there any workaround how to overcome that message and try it? Thanks for answer. MS
Hi everyone, I have KEPServerEX6 and I need to change options in property editor. When I change option and click apply settings is confirmed but when I runtime connect the setings change to previous. Tell me why?
When attempting to activate my Kepserver Licence by loading a Request File to generate a Response File, I get the following error and no response file is generated. Error: - callout failed with reason - Error processed during activation: 6011:Attribute Trusted Host Entity is required in the definition of {1}. This is after repairing a Trusted Storage error by following CS313362 and CS293892. Installation is now appearing as "new" with no activated license, and license key has been reset on MyKepware and is showing 1 activation available. No issues generating the request file. No Internet connection is available from the machine.
facing this error required solution tried restarting TomCat and KepWare still of no use
Hi all, I am using Thingworx 8.4.3 and Kepware 6.6. I have established the connectiving between Thingworx and Kepware successfully. But somethime there is an error on Kepware "Device is not Responding", but I don't see any change in my signals. The quality of signals is good. I want to raise an alert/ alarms whenever this error occurs. Is there any way where I can store this error into some Tags on kepware and then fetch that tag to thingworx and then raise an alarm or from kepware itself an alram can be generated ? Thank you!
Hello, this is my first post, I search a solution to programmatically run an export 'xml' of all PLC from Kepware V5.21. I search on porwershell via Get-Command without any result. Someone already solve this please ?
There is an Major Disadvantage of the KepServerEX or OPC Aggregators is that, they can only connect to single Industrial Connection of Thingworx. Let's Say there are 3 environments (Dev, QA, PROD). As of now, using three VM's to Connect to each Single Env from KepServerEX.Isn't a way where all three KepServerEX can be run on the same VM such that VM cost can be Cut ?@paic @c_lowy @slangley @CarlesColl @VladimirN @AnnaAn ThanksShashi.
Hi, I have issues with thing properties bound to remote Kepware tags. The Kepware tags are connected to OPC-UA endpoints and they all work and are updated as expected in the Quick OPC-UA client. The Industrial Connection status is connected and the bound properties display as healthy. But when the Kepware values change, the properties are not updated. Refreshing the thing properties does nothing, but when I save the thing, then the values are updated. The strange thing is this only happens on some bound tags and not all of them. The applicationkey is created with the admin user for testing purposes right now. Does anyone have similar experiences? Regards JK
Hello, We are using MFA, and we've configured a connection to Kepserver with an asset and remotely bound properties to Kepserver tags. The connection pushes values every seconds (in monitoring section we view that we receive it every second), and we need to log those values even haven't changed. Remoted bound properties Data Change Type property is set to Always, but QueryPropertyHistory service does't show a value for every second, only the changes. How can we get it? Thanks in advance
Hi Expert Community,I have an application that requires to read data using Modbus serial at a fix rate (for example every 5 minutes). The complete data read by Modbus should be published using IoT Gateway MQTT. However an additional requirement is that using the System tag for DemandPoll, the MQTT client should trigger a new Modbus acquisition and also get the new set of values published immediately.Can you suggest how the scan rate in Modbus and in IoTGateway should be configured?Regards,
Is it possible to transfer a file using kepware to thingworx. we have a case where thingworx and file both are present in same network but thingworx is in cloud. There are csv files that are written after a set of interval on a local computer. we need to use the same data for visualizing in a mashup.
Hello Everyone, We have applied a policy that has removed our administrator permissions. Its possible to execute the application without admin rights? Thanks a lot!
Hello. I am trying to connect RF Receiver and Kepware. What's the best way to make this connection? Do I need to convert the signal to a protocol supported by Kepware?
Hello, Is it possible to Read Json file and update Tag values in Kepware?. We have a legacy system which creates JSon files with the data and we would like to have this data in Kepware Tags. Thanks & Best Regards, Gowtham K.
Is there a way to get a demo license (more than 2 hours) so I can commission a new server with the latest kepware software? I don't want to have to take down production in order to do my commissioning. Other software has been able to provide a 30 day license or something.
Hello, i am trying to connect ABB FLowx flow computer to Kepware OPC server- KEPServerEX V6. Added it as OMNIFlow computer to KEPWARE OPC server with tags but with no success in collecting data from tags.. Can i get some info what to do or tutorial on this topic?
Hey all, Hopefully someone might of had something similar happen to them. We have a number of mould machines, ranging from kraussmaffei, fanuc, engel etc.... We have a reoccurring issue where the kraussmaffei mould machine (Connected to Kepware via Euromap 63) gets shut down for batch changes or maintenance, After a couple hours, the whole of kepware will go down for all the other moulds. We tested this by disabling kepware for the kraussmaffei machines, and not had any issues since. But we've been unable to narrow down, or really begin on what could be causing this. Any suggestions on where to begin? What to look out for in the event logs? What causes "bad data quality" to the point it breaks?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.