Recently active
Hello All, I am tring to update my local Thingworx instance with SSL (self-signed certificate) using the article Getting the error as "unable to load security provider" in Tomcat log, and Thingworx URL not loading as well. Thanks!
I have a customer who wants to discontinue their use of DPM, but wants to keep their ThingWorx base license to support a different custom application. The custom application and DPM are on the same instance of ThingWorx. Is there a best practice to remove or deactivate the DPM entities and/or extensions? Is there any risk to the custom application that we should be aware of while deactivating DPM?
Hello All,How to configure alarm on derived property as in AMU, as only properties displayed while alarm configuration, is the property configured during AMU configuration? For example, I have created a new property in ThingShape which is added in Asset Thing Template, and I am setting value in it using subscription and want to create Alarm on that value, is there any OOTB solution in AMU.
Hi, In CWC, I see '_ap' tables in the database. I remember back in 2021, I could add the custom columns _ap in manufacturing apps, and there was documentation of steps to add customer fields/columns from thingworx composer in _ap tables. Can someone share the importance of _ap tables? Why and how are they used?Thanks,
Dears: I wanna delete a value stream which is not enabled, but error occurs as below. what should I do to delete this value stream? Thanks!
Kepware Quick Client showing differenct time from the server time. Is there any way to fix this issue
InitializeSolution service (PTC.Base.Manager Thing) gives more than 100 script log error, and those are not being traced while debugging.for example, it says database credentials are incorrect however while checking persistent provider is say connected. Followed below guideline for DPM 9.7.0DPM Customer Deployments
Hi, I want to discuss something, lets say I have a sensor that sends me readings and also the time stamp of this readings, this timestamp is not the same as the timestamp of the machine that runs thingworx and the database, so i want thingworx to use this timestamp that came with the sensor data to store it in the database as the timestamp of the readings, so that when i try to query these readings and say i want it from timestamp 1 to timestamp 2 they will be stored in the database with timestamp 1 & 2 that has been set using a timestamp originally from the sensor data not the machine or server timestamp, when looked into it i found that i have to use this function in my subscribers and cancel the need to the log checkbox in the properties UI . // Log multiple properties in a single ValueStream entry Things["ValueStreamThingName"].AddStreamEntry({ source: me.name, tags: undefined, timestamp: timestamp, values: { Temperature: me.Temperature, Humidity: me.
A suggestion box is appearing upon clicking in the middle of the text-field widget as shown below:How to hide this suggestion box. Regards,Priya
Hello everyone,Currently I am working with Thingworx and Javascript. I am trying to do an API request from a SQL Query in Thingworx, having the following data: Thing: Test WPSQL (Query) Service: getTestService content:Select * from public.countries no inputs requiredoutput infotable (i changed to json, but got an error, infotable is successfull) Using Postman to try to test it:GET [Thingworx_Server]Thingworx/Things/Test%20WP/Services/getTest Params:Accept=application/jsonContent-Type=application/json Headers:appKey: Application Krey created on Thingworx Using GET I got 405 response, if I change it to POST, I got:<head> <title>Unexpected Error</title> <script> function clickAndDisable(link) { link.onclick = function(event) { event.preventDefault();
In platform-settings.json, I set timeout to 1 hour t generate around 200 reports in Production Server. "BasicSettings": { ... "ScriptTimeout": 3600 }, Due the performance of production server, some times 92 reports generated in one hour and sometimes 150 reports generated in one hour. So shall I increase script timeout to 2 hours. Ex: "BasicSettings": { ... "ScriptTimeout": 3600 }, ??? In Article - CS321502 - Service script times out with error Execution of Script terminated after : 30 seconds in ThingWorx Platform, I found that 'increasing the timeout limit of services too high could impact the performance of other areas of the application'.https://www.ptc.com/en/support/article/CS321502 Is it okay if iam increasing timeout to 2 hours for scheduler ?
Hello I have a mashup where i am using grid and I want to dynamically change the columns during runtime,Can someone please help me how to do it? Thanks
Hello Can someone please share sample entity or example to help me configure the chart in Thingworx? Thanks
I have a thing entity which has a set of properties, i want to add a new column to one of the thing properties which is a infotable. For example I have a property named "metatdata" which is a value collection which has a lot of other properties, i want to update one of these properties which is a infotable for example "Data1". This table has 2 columns "column1" and "column2", I want to add a new "column3" here and after that i need to update the values also for the new column. Thanks.
I want to display a model popup after clicking a button.In which the General Information is to be visible for the user.
I have a pdf file in my system repository. How can I access that pdf kept in System Repository?
Hi guys, I'm trying to pull data from 3 different Rockwell PLCs, however the data is reading and writing incredibly slow! I added the PLC to another Kepserver and it polled the data instantly. Any ideas what I'm doing wrong and why it is so slow? KepServerEX 6.17, V6 17.240.0
I have made a button linked with a link widget.If i click a button a pdf file should be download automatically. That pdf is stored in System Repository. How to make that?
We have created custom mashups for AMU. Our mashup flow: Base mashup --> Button click (Navigation) --> Navigate to new mashup with "Replace" behaviour. I'm able to add into the AMU menu. But, when I'm clicking the button to navigate to new mashup, it doesnt taking AMU master. It's replacing with the mashup alone. Base Mashup: New Mashup: When click the button from base mashup @mstarnaud
when uploading the license activation response, I get an error that trusted storage is not available. Please help me
I'm using kepware datalogger. I have configured different DSN for different table login purposes. All the loggers were working fine in the application server. And suddenly this happening randomly for dataloggers Unable to query recordset on Log Group Reason: ConnectionWrite (send()).General network Error. Does anyone have any idea what this error means and how to resolve it ? Already the application is in live mode. But this is happening randomly. Network side everything was good having good ping.
Hello Developers, I m trying to upgrade my running ThingWorxFoundationMSSQL-9.5.4-x64 on windows by using ThingWorx-Platform-Mssql-version-9-6-0 war file. I did all the steps which are mentioned on ptc page but it did not work. So can anyone please help me to upgrade Thingworx? Thanks.
The latest release of ThingWorx, version 9.7, brings powerful updates across performance, scalability, security, and developer productivity. Designed to meet the evolving demands of IoT and AR solutions, this version equips businesses with the tools to build smarter applications, improve operational efficiency, and stay ahead of the curve. Performance & ScalabilityThingWorx 9.7 introduces key updates that enhance performance and scalability for large-scale operations. The addition of partitioned value streams enables faster queries and purging of massive data sets, streamlining data management. Lazy loading for grid components optimizes application responsiveness, ensuring a seamless user experience, even in data-intensive environments. Additionally, the new Data Ordering feature ensures that ingested data is processed in the exact order it is received, even across asynchronous systems. This capability guarantees accurate execution of application logic and precise end ca
No errors that I know of but the server was rebooted around 7pm last night and the Ignition HMI server could not get any data until I logged into the KEPServerEX server and opened the KEPServerEX Configuration client. I did nothing else, This has happened before. How do we make sure that the OPC UA connection survives a reboot?
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.