Recently active
Hi Does anyone have any idea how to resolve the following error in Anomaly training: Returning a FAILED state for TimedValue [timestamp=1551249937059, value=29.32]. ThingWatcherMessage [timestamp=2019-02-27T08:45:34.678, severity=ERROR, state=ThingWatcherInternalState [internal=OBTAINING_MODEL, external=TRAINING], messageCode=WAT1001E, messageText=Operation exception. {Throwable=[Trainer.TrainingJobErrorException: Training job with id null entered into an incomplete state [UNKNOWN] unable to process models. Error message: [Job was queued but is no longer being considered.]}]]_com.thingworx.analytics.thingwatcher.exceptions.ThingWatcherOperationException: Error accessing PMML Model URI, cannot download model_ at com.thingworx.analytics.thingwatcher.ThingWatcherInternal.isModelAvailableAfterTraining(ThingWatcherInternal.java:699)_ at com.thingworx.analytics.thingwatcher.ThingWatcherInternal.runStateMachineFor(ThingWatcherInternal.java:460)_ at com.thingworx.analytics.
Hi, By programming, how could i retrieve a list of entities in a project? My Bests, Hung Tran
Is it possible to copy entire row from grid widget or advanced grid? copy paste to excel.
A similar problem was described and solved for previous versions of THX: https://community.ptc.com/t5/Manufacturing-Apps/Control-Advisor-App-Kepware-server-added-but-not-visible/m-p/538017The solution to this issue was to install updates. What can be done in this case? Versions : Windows 7x64 maximum SP1Tomcat 8.5.30Postgres 10.3.3ThingWorx 8.3.3-b937Manuf Apps 8.3.1 ExtensionIndustrial Connectivity 8.3.65 Everything is installed and run smoothly. Connection with TWIC and tags are available in the composer. But the problem I have is that in my App Control Advisor, the list of Servers is empty.Even when I add new server the created server is not displayed. If i try to create the server again in the Control Advisor App a message tells me that the server already exists, which is normal. All screenshots are similar to the post to which I refer. Thank you, Peter.
Hello, I'm fairly new to Thingworx and trying to get some first steps done by connecting a Pi to Thingworx, following the Raspberry Quickstart guide. (https://developer.thingworx.com/en/resources/guides/thingworx-raspberry-pi-quickstart/) EMS is 5.4 I'm using a own thingworx installation. First my config.json: { "ws_servers": [{ "host": "twxdemo.inneo.cloud", "port": 443 }], "http_server": { "host": "127.0.0.1", "port": 8080, "ssl":false, "authenticate":false }, "appKey": "xxx", "logger": { "level": "INFO" }, "auto_bind": [{ "name": "PiThing", "gateway": false, "host": "127.0.0.1", "port": 8001 }], "certificates": { "validate": false, "allow_self_signed":true }, "ws_connection": { "encryption": "ssl", "verbose": true, "msg_timeout": 1000 } } It does connect: pi@raspberrypi:~/microserver $ sudo ./wsems [FORCE] 2019-02-25 12:25:10,253 ./wsems: Initializing EMS .... [FORCE] 2019-02-25 12:25:10,253 main: Using config file /home/pi/microserver/etc/
Just downloaded Thingworx demo and KEPServerEX 6.6 When I tried to connect KepServerEX, I got the following error: "ThingWorx Native Interface Connection to ThingWorx failed. | Platform = <servername>:<server port>/Thingworx/WS, error = unknown error." In summary, I think the issue was that you can not use the name "localhost" for your server name. I checked that I had correctly setup all my ThingWorx items in Property Editor (Enabled, host name, port, application key, etc.) However, I kept having problems. I thought the problem was the application key, so i entered a bad application key and I got a different error (authentication error). I tried changing the socket from 9080 to the example's 8080 and got a socket error. After going into the thingworx controls advisor and deleting the server and then adding a new server called "TestServer" instead of "localhost", it now works. I'm writing this post in hope that either someone ex
We have ThingWorx installed on an AWS EC2 server and are interested in utilizing a S3 bucket for user repositories. Can this be done? If so, how? -Tim
Hi! I am trying to use Building process for Docker Images for Thingworx H2 8.4. Eveyrthing seems to be ok, but at the end I am receiving this error while LicenseSubsystem is starting: platform_1 | 2019-02-21 16:07:57.751+0000 [L: INFO] [O: c.t.s.s.Subsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Starting Subsystem [TunnelSubsystem] platform_1 | 2019-02-21 16:07:58.134+0000 [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Subsystem TunnelSubsystem is started platform_1 | 2019-02-21 16:07:58.334+0000 [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Subsystem MessageStoreSubsystem is starting platform_1 | 2019-02-21 16:07:58.630+0000 [L: INFO] [O: c.t.s.s.Subsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Starting Subsystem [MessageStoreSubsystem] platform_1 | 2019-02-21 16:07:58.683+0000 [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localho
The application that is being developed is having some problem viz.., when i hover over the time series chart data points, the application shakes frequently. It would be helpful if someone could give inputs on this.
Hi i need find yesterday date and also i need to set hours also, but if i used sethours function datetime format automatically convert into number , if i apply function setDate on offset value it will thourgh error? here is code var d = new Date();var c =d.setHours(00,00,00,000);var result =c.setDate(c.getDate() - 1); i needto find yesterday date and hours should be 00,00,00,000
Hi, When attempting to reset a users password through an organizations formlogin the email generated contains an invalid URL. My ThingWorx instance is configured to use SSL, but the URL generated in the email does not use it and instead creates a regular http link which does not work. According to https://www.ptc.com/en/support/article?n=CS253539 this issue was solved in TWX 7.2.0 but I am still experiencing it in ThingWorx 8.3.0-b349. /M
Hi all, We are implementing Operator Advisor (in TW 8.4). It's clear that every table in the database has a copy in ThingWorx as a DataShape, also junction tables. I'm wondering, what is the best way to show data from multiple tables in the database? The way I see it there are two options: 1. Use the Operator Advisor database services and make multiple calls and do intersects on the infotables you'll get as an answer. 2. Write your own JOIN query's in the database thing and display the answer in a datatable. Another question leaning on the previous question: What datashape do you use when you display the joined data? Or do you make a new DataShape for every new call?
Hi, I need to create a large number of mashups and was wondering if there is a faster way to do so than navigating the composer and creating them manually. Is there a way to solve this problem programmatically, i.e. automate the creation process when given a list of mashup names? Thanks in advance!
Is the "Disabled" property of the Button widget not available anymore? I see it in Figure (b) in the following post, but I cannot find it in my Button properties https://community.ptc.com/t5/ThingWorx-Developers/how-to-disable-a-Button/td-p/526174 I am running Thingworx 8.3.2-b535 I know it can be made visible/invisible, but I prefer to make it disabled/enabled.
Hi, We are trying to publish our customizations as an extension but we run into issues with some of our Things. The problematic Things have locally bound properties and when we create an extension containing those things the error log shows errors like these: [context: Extension Exception][message: Error parsing C:\Program Files (x86)\ThingworxMSSQL-1.2.0-SNAPSHOT\ThingworxStorage\extensions\temp\Support_3183c8b2-84b6-4642-93e9-8b62d370a52b\Support\Entities\Downloads\Things_TomTestLinkedPropertiesThing.xml: (64, 64): cvc-complex-type.3.2.2: Attribute 'aspect.source' is not allowed to appear in element 'PropertyBinding'.] I tried manually removing the attribute but then the validation fails on aspect.startType or aspect.tagAddress. I created a simple thing with one property locally bound to cleanupoldsessionstimer, exported it to source control entities and created an extension using Eclipse and it already fails. You can find the exported thing and generated
Dears, When I use Administrator account , I can create service SQL (Query). But when I use other account, I can't create service SQL (Query). Could anyone help me this problem ? Thank you~
Hi, I have a datashape that contains infotables, and some of these infotables also contain infotables. My goal is to display the "root" infotable in one grid, and the nested infotable in another grid when the selected row changes in the root grid. The images below display my current configuration that is not working: I've read about similar situations but have not been able to solve it. According to https://community.ptc.com/t5/ThingWorx-Developers/Selected-row-s-problem-with-infotable-in-infotable/m-p/550168#M28657 this was solved in TWX 8.3.0 but I am on 8.3.2 and there is nothing showing the nested grid when selecting a row. I am using advanced grid version 4.0.1, but have also tried advanced grid 4.2.0 and neither work. /M
I would like to monitor a user's idle time. That way, I can logout a user just prior to the normal session timeout and navigate the user back to the FormLogin page of the user's organization. Thanks, Tim
Hello together, i would like to create a Mashup which shows different tiles for different functionalities. The PTCCovergeConsole, see attachement, is doing this. My question is how do I make those tiles and can I link a mashup to each tile? Thanks for your help. Regards Felix
We are trying to perform something like thisFlex/Windchill and ThingWorx are installed in Lab on 2 ServersThingworx is configured to have Windchill as Authentication Service (With Windchill Extension), so SSO works when navigating from Windchill to Thingworx, in case a user is not there, TW creates it as logins-ina. e.g. sourcing_user_1 from Windchill navigates to TW, a user with same name is created and logged in without asking for password.SSO is working fine for thingworx with windchill.Now , we a 3rd Party app which uses REST calls from TW to access data from TW + WindchillI need to achieve a seamless login (or SSO) from TW to REST API – which I am not able to TW REST API can only accept Base64 – Basic Auth for REST API authentication, but we can never have password as we are only getting username as SSO from Windchill, this is tricky situationIdeas is to achieve some kind of seamless auth from Windchill à TW à REST API (App)Any ideas will help,
I am trying to follow the sample setup from PTC and am having difficulty in that the IoT Gateway starts, finds the JRE "KEPServerEX\IoT Gateway IoT Gateway using JRE at [C:\Program Files (x86)\Java\jre1.8.0_191]" Then the IOT Gateway service stops. Why? How do I determine the cause of this? The Custom Controls Advisor cannot be used due to connectivity issues. Thanks, John
1. NodeMCU ESP8266 using Arduino: can't update the value in thingworx foundation platform but serial monitor is showing the updated value continuously. Please Ref Image1_serialmonitor_output. 2. Also, on platform side there is one red color symbol 'disconnected', showing that my created thing 'NodeMCU' is not connected. You can find that symbol in attached image2, below search option. 3. Also find the attached code file. I guess code is using HTTP Client for coonecteion but the server is HTTPS (https://pp-xxxxxxxxxxxx.devportal.ptc.io). If this is the issue Please suggest me which library to use?
Hi, We have created a custom jsp page for login in Thingworx. If the user enters wrong credentials 5 times within 5 mins it's geeing locked and will be unlocked after 5 mins, but the same user wants to login through the jsp Page it's giving wrong credentials even with valid user name and password. But in the composer user will be active and unlocked and they can be logged to the composer but not into the organization. Is there any specific reason for this issue. Please kindly let me know the solution.
I want to add asset and line type to create equipment pop up panel as in the attachment. Also, I want to assign asset detail mashup to each asset or line type. If possible, let me know the way.
Hi i am using thingworx 8.2 .my list widget is not working properly after i imported a set of entities for my new project . . i have attached two images here . one is my workspace (where you can see list widget is used and binded to data ) and other is my runtime view of mashup (list item is missing ) . can you pls help me understand what might be the problem for this thanks, swetha
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.