Take the Windchill Satisfaction Survey!
Recently active
I've to do a migration from KEPServerEX 5.8 to KEPServerEX 7, step by step, using a BRIDGE KEPServerEX 7 solution, that initially it is connected in OPC-UA to all OLD channel/device/tags of KEPServerEX 5.8.Then in a new Server with KEPServerEX 7 we migrate step by step each original channel, then connecting the BRIDGE to the new one migrated.Finally we will have the BRIDGE only linked in UA Client to the new KEPServerEX 7 migrated, and no more to the old one KEPServerEX 5.8. Now we are testing this migration scenario creating in Kepware 7 BRIDGE an OPC-UA Channel to Kepware 5.8 OLD, but we have some issue when the remote Channel in Kepware 5.8 is it self an OPC-UA driver.In some cases, the tags seems to be unknown and in bad quality, why ?The issue happen also if I try to read the remote TAGs via UAExpert tool To understand/replicate the issue I have done also another example locally, in order to exclude network and OPC-UA configuration, both in
We are currently experiencing a performance issue with our OPC UA communication. We have an application developed in FactoryTalk View SE version 15, which displays several graphical screens that rely on data coming from Kepware 6 through an OPC UA connection.The problem is that the graphical elements take a long time to receive updated information from Kepware. The data refresh rate is significantly slower than expected, causing delays in the visualization of real‑time values.We would like to understand what could be causing this slow performance and what actions we can take to improve the responsiveness of the OPC UA communication. Specifically, we are looking for recommendations to optimize OPC UA settings, data update rates, server load, or any other configuration that could help increase the communication speed between Kepware and FactoryTalk View.
HelloWhere can i download LinkMasterThanks,
In whatt condition or when the following information appears in event log:Allen-Bradley ControlLogix Ethernet MainLine.DATA_LOGGER | Details. | IP = '<10.3.XX.XX>,1,0:44818', Vendor ID = 1, Product type = 14, Product code = 168, Revision= 30.11, Product name = '1756-L85E/B', Product S/N = 0XE46E97.
Hi,We currently have around 30 KEPServerEX installations with perpetual (node-locked) licenses on different machines. We are planning to replace those machines one by one, but we want to make sure we do the transfer correctly without risking:• losing the licenses• having them become invalid• or incurring additional costsWe understand that the standard procedure is to use License Utility → Transfer a product activation to generate a transfer request file, upload it to the PTC licensing portal, and then activate the license on the new machine.However, in our case, we do not currently have access to the original PTC licensing account / login information that was used when these licenses were activated. This is one of our main concerns.Before we proceed, we would appreciate clarification on the following:Is the above transfer procedure the correct and safe way to move node-locked perpetual licenses to new machines without penalty?Since we do not have the original account credentials, what
I have a python code that reads data from excel and sends to kepware, I am trying to set this up and setup the tags in kepware as a server, and the python as a client. This will eventually be connected to a DeltaV system which is another client, but for now I want to test my code sending data into Kepware. Which drivers should I use for this purpose?
Hi, i am not able to login to MyKepware portal, alwas getting a message "We've made changes to My Kepware. Please log in again. Please advise, i have to activate a Kepserver license. Thx.
Hello,I'm getting this error: Connection not established. Retry ? (you can work offline by selecting 'NO')Data collection stopped for no reason. Rebooted the server and getting this error KEPServerEX\Configuration Connection attempt to runtime failed. | Runtime host address = '127.0.0.1:32402', User = 'Default User', Reason = 'This operation returned because the timeout period expired.'. Version: 6.7.1067Any ideas ?
Hello, I am trying to configure Atlas Copco Micro Torque MTF 6000 in Kepware and as per device documentation the MIDs for this device are used differeltly than that of full Atlas Copco Open Protocol. e.g. My question here is, how should I use the MID 008 to read the last torue value, I know that in device settings there is an option to enable the use of generic subscibe which enables MID 008, but what will be the tag address then for torque value? or it will be same "LTR_TORQUE_VALUE". (FYI I am a Thingworx developer & have a limited orientation towards industrial protocols & their working)
Kepware server 7 comes with Audit Trail.The Min days to preserver max limit is 90 days. Details on this in the help menu is very vague.Is it fully 21CFR part 11 compliant, if it only preserves for 90 days? What is the recommended method to preserve audit log files indefinitely?and also allow for an audit log report to be generated.
Hello,I have wonder, does kepware datalog driver has any custom data logging parameters ? for example I want to log a carrier ID everytime the ID is change and not the associate think in the same table (such as weight, material etc). The normal logging is based on the change of all logged item and not a singular item. Thanks alot.
Hi!I have upgraded from kepserverEX v5 to v6 on a new server, and tranfered the license:)My problem is that after a while all tags stops working and i see tag quality turns bad(Configuration error). It shouldnt be licens cause i see status on license utility=good. I then need to restart kepserver and it works again, so it kinda looks like license issue but idk how 😐 Anybody knows how to deal with this issue?
At the moment I have a small problem when getting the data from MQTT.I understood that Kepware can get the message from MQTT based on the JSON format, but when that format is not in the JSON, what should I do? For example, If my MQTT has a topic is "homeassistant/binary_sensor/IPC1" and the message of the topic is a string like 99-99-99-99 (not in the JSON format), how can I get the string 99-99-99-99 in Kepware? Any ideas?here is the picture for more understanding of my situation
I am prompted to enter in my Windows admin login, which I have done, but nothing works. I've re-installed the software several times but no means to turn it off, Any way to bypass? All I want to do is download my license.
Hello everyone. We use KepserverEx as OPC UA server and MCE get tags from KerserverEx. Looks like there are some limitation in Kepserver side, MCE can't get more than 1K tags at the same time, if exceed the limitation, the tags will be null.We tried to separate tags into several devices in Kepserver but didn't works.
Hi everyoneBasically I'm trying to log data into an SQL server, I get the correct tag value and tag name, but with the time I'm not able to see it correctly in SQL In SQL I have the column Time as data type: timestampand the data that logs is in hexadecimal, so is not what I wantI've actually use data type datetime2 as well in sql but then I get an error in Kepware (Error Data Logger Plug-in Unable to query recordset on Log Group 'loggroup'. Reason: Conversion failed when converting date and/or time from character string)You can see it in the snapshots does anyone know how can I actually submit the time in the SQL server? or like what datatype should be in Kepware and SQL? please help
I just installed V7 Data Logger and would like to be able to import 4,000+ log items. The connectivity suite has export/import capabilities. I don't see it for Data Logger. Is there a way to manipulate the log items via JSON, REST api, or other method?
Hi, I am adding a new Mitsubishi Ethernet iQ-R series PLC to an existing FTView SE SCADA which is using Kepware for comms. The issue is the addresses I need to add to the new Kepware config have not been mapped into contiguous blocks and are widely spread about. Will this be a problem if I create static tags in Kepware with such scattered addresses ? When I began working on SCADA systems in the 90's I was always told that any data that was to be read or written to by SCADA should be mapped into contiguous blocks, otherwise you would end up getting multiple read transactions which would affect comms performance. Is this still valid today with fast Ethernet and multi core CPU's ?
Hello everyone, I am trying to read data from Allen Bradley PLC. However, Kepserver is unable to read all the data. Below are few errors that are occurring: Date Time Level Source Event12/23/2025 6:20:52 PM Warning Allen-Bradley ControlLogix Ethernet | Unable to read tag. Controller tag data type unknown. Tag deactivated. | Tag address = 'PROGRAM:P09_INFEED.STCAMSBM1', Data type = 0XD37F. Date Time Level Source Event12/23/2025 6:20:52 PM Warning Allen-Bradley ControlLogix Ethernet | Unable to read tag. | Tag address = 'PROGRAM:P09_INFEED.FBSTARAXIS3', CIP error = 0XF, Extended error = 0X2100. Date Time Level Source Event12/23/2025 6:36:03 PM Error Allen-Bradley ControlLogix Ethernet | Database error. Unable to resolve CIP data type for tag. Setting to default type. | CIP data type = 0X8871, Tag name = 'OPT_PrintCheck', Default data type = 'DEFAULT'. Can anyone help me above issues please ? Regards,Danyal Shahzad
When will the Tia portal Exporter support Tia portal V20 Projects ? Greetings Frederik
Kepware version: Thingworx kepware Server v6.16.217.0We are having Fanuc Series 31i Model CNC machines.We have Fanuc driver specific libraries for communication.Issue: We would like to communicate with 31i model but the driver is not listing the 31i model.Any work around or I am missing something?
Hi every one!I’m experiencing an issue with Advanced Tags in our Kepware project and need guidance.Setup:Kepware version: [KepserverEx 6]Channels: K1,Devices: PLC1,Source tags: Boolean / WORD tags under devices (quality = GOOD in OPC Quick Client)Advanced Tags: created in the global “Advanced Tags” folderAliases: created pointing to Advanced Tags and mapped to the corresponding deviceProblem:All Advanced Tags show BAD quality in OPC Quick Client.Source tags themselves read correctly and have GOOD quality.Even a simple Advanced Tag referencing a single Boolean tag shows BAD quality.The “Mapped To” option is only available in the Alias — the Advanced Tag itself has no “Mapped To” field.We want to confirm:If this is the correct setup for reading Advanced Tags via OPC/AVEVA.Whether there are any licensing, runtime, or configuration steps we may be missing that prevent Advanced Tags from evaluating.Thank you for your guidance.
Hi all,Just can't get my head around one thing!I am using Kepware to log a group of tags -more than 1000 tags- apparently, Kepware’s DataLogger logs the entire group when any tag in that group changes. However, what I need is logging only those tags that have been changed not the entire group! I've done some research and ended up with enabling OPC UA in my project and using a Python code to log only the tags are changed! I was wondering if there is any other way except changing configuration of the project which I prefer to put it in bottom of my list!Any help much appreciated!
Hello, I need to upload activation request file to repair my broken license.But i can't login to my kepware account in myKepware.It just keeps loading and loading..."we have made changes to My kepware. Please log in again"
Python which got installed during API installation is 3.10 and having vulnerabilities.We need to upgrade Python, will it support? if not then can we just upgrade API.Whole Kepware Application version upgrade supposed to be last option for us.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.